summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-07 20:12:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-07 22:18:38 +0100
commita00968b7a878ab5aa0d0afb000f29e713b880674 (patch)
tree470f92706031812e3eec51943ceac8b6470191e0
parentb2dc4cb41ce107199c8899b89e1c4104d410370b (diff)
downloadgnu-guix-a00968b7a878ab5aa0d0afb000f29e713b880674.tar
gnu-guix-a00968b7a878ab5aa0d0afb000f29e713b880674.tar.gz
gnu: Add r-import.
* gnu/packages/cran.scm (r-import): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7281caf7a6..b256d228d8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2802,3 +2802,27 @@ dendrograms.")
Genomics Data Server (CGDS), hosted by the Computational Biology Center at
Memorial-Sloan-Kettering Cancer Center (MSKCC).")
(license license:lgpl3)))
+
+(define-public r-import
+ (package
+ (name "r-import")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "import" version))
+ (sha256
+ (base32
+ "0blf9539rbfwcmw8zsb4k58slb4pdnc075v34vmyjw752fznhcji"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/smbache/import")
+ (synopsis "Import mechanism for R")
+ (description
+ "This is an alternative mechanism for importing objects from packages.
+The syntax allows for importing multiple objects from a package with a single
+command in an expressive way. The import package bridges some of the gap
+between using @code{library} (or @code{require}) and direct (single-object)
+imports. Furthermore the imported objects are not placed in the current
+environment. It is also possible to import objects from stand-alone @code{.R}
+files.")
+ (license license:expat)))