summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2018-03-10 21:31:00 -0500
committerDavid Thompson <dthompson2@worcester.edu>2018-03-10 21:35:01 -0500
commit907254e513b8b50b0440b21d4deb34e7c4722ceb (patch)
tree6d892bb3a55371e79761d44db915b2269e3bd8f4
parent3c90c7ae37db57580f89e39468225d2901b2a513 (diff)
downloadgnu-guix-907254e513b8b50b0440b21d4deb34e7c4722ceb.tar
gnu-guix-907254e513b8b50b0440b21d4deb34e7c4722ceb.tar.gz
gnu: haunt: Update to 0.2.2.
* gnu/packages/guile.scm (haunt): Update to 0.2.2.
-rw-r--r--gnu/packages/guile.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index d39285460b..1e8aca1acf 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1259,14 +1259,14 @@ Guile's foreign function interface.")
(define-public haunt
(package
(name "haunt")
- (version "0.2.1")
+ (version "0.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://files.dthompson.us/haunt/haunt-"
version ".tar.gz"))
(sha256
(base32
- "1fpaf1vm6s7j13fs35barjh5yajcc2rc3pi8r7278wpgp4i2vs3w"))))
+ "0nm00krmqq4zmqi2irh35dbf2cn6al58s620hijmhfvhgvdqznlp"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 match) (ice-9 ftw)
@@ -1283,12 +1283,15 @@ Guile's foreign function interface.")
out "/share/guile/site")))
(match (scandir site)
(("." ".." version)
- (let ((modules (string-append site "/" version)))
+ (let ((modules (string-append site "/" version))
+ (compiled-modules (string-append
+ out "/lib/guile/" version
+ "/site-ccache")))
(wrap-program (string-append bin "/haunt")
`("GUILE_LOAD_PATH" ":" prefix
(,modules))
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,modules)))
+ (,compiled-modules)))
#t)))))))))
(native-inputs
`(("pkg-config" ,pkg-config)