summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-03-09 23:11:48 +0100
committerLudovic Courtès <ludo@gnu.org>2018-03-09 23:24:34 +0100
commit464f5447396fcec9b43f7eab71d5d42b522a157f (patch)
tree5d6eb998c752a1b375afae9c36df84dcb079f889
parentab9ad138025bdc01e286044e5de20bf03ad1c3b9 (diff)
downloadgnu-guix-464f5447396fcec9b43f7eab71d5d42b522a157f.tar
gnu-guix-464f5447396fcec9b43f7eab71d5d42b522a157f.tar.gz
gnu: 'autoconf-wrapper' is no longer a procedure.
Fixes <https://bugs.gnu.org/30710>. Suggested by Björn Höfling <bjoern.hoefling@bjoernhoefling.de>. * gnu/packages/autotools.scm (autoconf-wrapper): Rename to... (make-autoconf-wrapper): ... this. Add 'properties' field. (autoconf-wrapper): New variable. * gnu/packages/gnunet.scm (guile-gnunet): Adjust accordingly. * gnu/packages/gnupg.scm (signing-party): Likewise. * gnu/packages/guile.scm (guile-ics, guile-bash): Likewise. * gnu/packages/libevent.scm (libuv): Likewise. * gnu/packages/logging.scm (glog): Likewise. * gnu/packages/mail.scm (libetpan): Likewise. * gnu/packages/mate.scm (mate-icon-theme-faenza) (mate-screensaver): Likewise. * gnu/packages/package-management.scm (guix): Likewise. * gnu/packages/sawfish.scm (librep): Likewise. * gnu/packages/video.scm (motion): Likewise. * gnu/packages/zile.scm (zile-on-guile): Likewise.
-rw-r--r--gnu/packages/autotools.scm16
-rw-r--r--gnu/packages/gnunet.scm4
-rw-r--r--gnu/packages/gnupg.scm4
-rw-r--r--gnu/packages/guile.scm4
-rw-r--r--gnu/packages/libevent.scm4
-rw-r--r--gnu/packages/logging.scm4
-rw-r--r--gnu/packages/mail.scm2
-rw-r--r--gnu/packages/mate.scm4
-rw-r--r--gnu/packages/package-management.scm2
-rw-r--r--gnu/packages/sawfish.scm2
-rw-r--r--gnu/packages/video.scm2
-rw-r--r--gnu/packages/zile.scm4
12 files changed, 29 insertions, 23 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 846e318aa1..33addc11a7 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -124,8 +124,8 @@ know anything about Autoconf or M4.")
(string-append "--build=" build)))))))))))
-(define* (autoconf-wrapper #:optional (autoconf autoconf))
- "Return an wrapper around AUTOCONF that generates `configure' scripts that
+(define (make-autoconf-wrapper autoconf)
+ "Return a wrapper around AUTOCONF that generates `configure' scripts that
use our own Bash instead of /bin/sh in shebangs. For that reason, it should
only be used internally---users should not end up distributing `configure'
files with a system-specific shebang."
@@ -191,7 +191,13 @@ exec ~a --no-auto-compile \"$0\" \"$@\"
(patch-shebang "configure"))
(exit (status:exit-val result))))
port)))
- (chmod (string-append bin "/autoconf") #o555)))))))
+ (chmod (string-append bin "/autoconf") #o555)))))
+
+ ;; Do not show it in the UI since it's meant for internal use.
+ (properties '((hidden? . #t)))))
+
+(define-public autoconf-wrapper
+ (make-autoconf-wrapper autoconf))
(define-public autoconf-archive
(package
@@ -253,7 +259,7 @@ output is indexed in many ways to simplify browsing.")
(search-patches "automake-skip-amhello-tests.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,(autoconf-wrapper))
+ `(("autoconf" ,autoconf-wrapper)
("perl" ,perl)))
(native-search-paths
(list (search-path-specification
@@ -348,7 +354,7 @@ Makefile, simplifying the entire process for the developer.")
("perl" ,perl)
("help2man" ,help2man) ;because we modify ltmain.sh
("automake" ,automake) ;some tests rely on 'aclocal'
- ("autoconf" ,(autoconf-wrapper)))) ;others on 'autom4te'
+ ("autoconf" ,autoconf-wrapper))) ;others on 'autom4te'
(arguments
`(;; Libltdl is provided as a separate package, so don't install it here.
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 29bfc8199f..f4eacd3023 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
-;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
@@ -327,7 +327,7 @@ kinds of basic applications for the foundation of a GNU internet.")
(lambda _
(invoke "autoreconf" "-vfi"))))))
(native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,(autoconf-wrapper))
+ ("autoconf" ,autoconf-wrapper)
("automake" ,automake)))
(inputs `(("guile" ,guile-2.0)
("gnunet" ,gnunet)))
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index eeab5c5afd..28f5b58887 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -618,7 +618,7 @@ PGP keysigning parties.")
"1n5bpcfpl9vg1xp6r1jhbyahrgdyxp05b5pria1rh4m0qnv8sifr"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,(autoconf-wrapper))
+ `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)))
(inputs `(("perl" ,perl)
("perl-text-template" ,perl-text-template)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 91a440d928..bfcb32531f 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -769,7 +769,7 @@ format is also supported.")
(symlink "README.org" "README")
(zero? (system* "autoreconf" "-fi")))))))
(native-inputs
- `(("autoconf" ,(autoconf-wrapper))
+ `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("texinfo" ,texinfo)
;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
@@ -1856,7 +1856,7 @@ dictionary and suggesting spelling corrections.")
(string-append "--libdir=" (assoc-ref %outputs "out")
"/lib/bash"))))
(native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,(autoconf-wrapper))
+ ("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)
;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 9d96e651ac..d6b70a4f17 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
@@ -140,7 +140,7 @@ limited support for fork events.")
;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
#:tests? #f))
- (native-inputs `(("autoconf" ,(autoconf-wrapper))
+ (native-inputs `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 27557e1b1b..f50a2f1cbb 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -73,7 +73,7 @@ staying as close to their API as is reasonable.")
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl) ;for tests
- ("autoconf" ,(autoconf-wrapper))
+ ("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)))
(arguments
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 7d85d5208a..7986671e97 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -931,7 +931,7 @@ useful features.")
(sha256
(base32 "1sxnaglp5hb0z78sgnfzva4x8m4flqhicvm1dz0krkxdmfsafrsf"))))
(build-system gnu-build-system)
- (native-inputs `(("autoconf" ,(autoconf-wrapper))
+ (native-inputs `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index b892a768d8..0281b02daa 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -135,7 +135,7 @@ MATE applications.")
(setenv "CONFIG_SHELL" (which "sh"))
(invoke "sh" "autogen.sh"))))))
(native-inputs
- `(("autoconf" ,(autoconf-wrapper))
+ `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("intltool" ,intltool)
("icon-naming-utils" ,icon-naming-utils)
@@ -1191,7 +1191,7 @@ Re-decorates windows on un-maximise.
(("dbus-1") ""))))))))
(native-inputs
`(("automake" ,automake)
- ("autoconf" ,(autoconf-wrapper))
+ ("autoconf" ,autoconf-wrapper)
("gettext" ,gettext-minimal)
("intltool" ,intltool)
("kbproto" ,kbproto)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 6ec70b12fe..709cdfd0f7 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -239,7 +239,7 @@
;; XXX: Keep the development inputs here even though
;; they're unnecessary, just so that 'guix environment
;; guix' always contains them.
- ("autoconf" ,(autoconf-wrapper))
+ ("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("gettext" ,gettext-minimal)
("texinfo" ,texinfo)
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index 9f9264457d..ede725877d 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -58,7 +58,7 @@
`(("makeinfo" ,texinfo)
("pkg-config" ,pkg-config)
- ("autoconf" ,(autoconf-wrapper))
+ ("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)))
(inputs
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7d072009a0..dfd94f9d3b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2761,7 +2761,7 @@ It counts more than 100 plugins.")
(file-name (string-append name "-" version ".tar.gz"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,(autoconf-wrapper))
+ `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("pkg-config" ,pkg-config)))
(inputs
diff --git a/gnu/packages/zile.scm b/gnu/packages/zile.scm
index c0bbafdd59..fd3d168b3d 100644
--- a/gnu/packages/zile.scm
+++ b/gnu/packages/zile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -102,7 +102,7 @@ default Emacs configuration, but it carries a much lighter feature set.")
,@(package-inputs zile)))
(native-inputs
`(("m4" ,m4) ;for 'bootstrap'
- ("autoconf" ,(autoconf-wrapper))
+ ("autoconf" ,autoconf-wrapper)
("automake" ,automake)
;; For some reason, 'bootstrap' insists on having these.