summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-07 23:07:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-07 23:25:36 +0100
commit0bdd5b8ab7c5e618a63cac6d9aa55f9cf674deea (patch)
treedbd4a90831a6578fae10d462903a2be906be5ef8
parente2cafc2449df16ccc3ca1555d5e9ed66908d846e (diff)
downloadgnu-guix-0bdd5b8ab7c5e618a63cac6d9aa55f9cf674deea.tar
gnu-guix-0bdd5b8ab7c5e618a63cac6d9aa55f9cf674deea.tar.gz
gnu: Add pigx-rnaseq.
* gnu/packages/bioinformatics.scm (pigx-rnaseq): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 546b240f84..d6c7c05dd5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12646,3 +12646,70 @@ contains
analyze RNA expression genome-wide in thousands of individual cells at
once. This package provides tools to perform Drop-seq analyses.")
(license license:expat)))
+
+(define-public pigx-rnaseq
+ (package
+ (name "pigx-rnaseq")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/BIMSBbioinfo/pigx_rnaseq/"
+ "releases/download/v" version
+ "/pigx_rnaseq-" version ".tar.gz"))
+ (sha256
+ (base32
+ "168hx2ig3rarphx3l21ay9yyg8ipaakzixnrhpbdi0sknhyvrrk8"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-tests? #f ; not supported
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ ;; Make sure the executable finds all R modules.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/pigx-rnaseq")
+ `("R_LIBS_SITE" ":" = (,(getenv "R_LIBS_SITE")))
+ `("PYTHONPATH" ":" = (,(getenv "PYTHONPATH")))))
+ #t)))))
+ (inputs
+ `(("snakemake" ,snakemake)
+ ("fastqc" ,fastqc)
+ ("multiqc" ,multiqc)
+ ("star" ,star)
+ ("trim-galore" ,trim-galore)
+ ("htseq" ,htseq)
+ ("samtools" ,samtools)
+ ("bedtools" ,bedtools)
+ ("r-minimal" ,r-minimal)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggrepel" ,r-ggrepel)
+ ("r-gprofiler" ,r-gprofiler)
+ ("r-deseq2" ,r-deseq2)
+ ("r-dt" ,r-dt)
+ ("r-knitr" ,r-knitr)
+ ("r-pheatmap" ,r-pheatmap)
+ ("r-corrplot" ,r-corrplot)
+ ("r-reshape2" ,r-reshape2)
+ ("r-plotly" ,r-plotly)
+ ("r-scales" ,r-scales)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)
+ ("r-crosstalk" ,r-crosstalk)
+ ("r-tximport" ,r-tximport)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-rjson" ,r-rjson)
+ ("salmon" ,salmon)
+ ("ghc-pandoc" ,ghc-pandoc)
+ ("ghc-pandoc-citeproc" ,ghc-pandoc-citeproc)
+ ("python-wrapper" ,python-wrapper)
+ ("python-pyyaml" ,python-pyyaml)))
+ (home-page "http://bioinformatics.mdc-berlin.de/pigx/")
+ (synopsis "Analysis pipeline for RNA sequencing experiments")
+ (description "PiGX RNAseq is an analysis pipeline for preprocessing and
+reporting for RNA sequencing experiments. It is easy to use and produces high
+quality reports. The inputs are reads files from the sequencing experiment,
+and a configuration file which describes the experiment. In addition to
+quality control of the experiment, the pipeline produces a differential
+expression report comparing samples in an easily configurable manner.")
+ (license license:gpl3+)))