summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-02 22:22:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-02 22:23:18 +0100
commit1088744d8748a4ed81accdacab95eb397de0f23b (patch)
treeec286c0125719696fae18a5c82c20c23ad7e54c3
parent07a2f34d5c8342b88530f8cb968090eccd0da91c (diff)
downloadgnu-guix-1088744d8748a4ed81accdacab95eb397de0f23b.tar
gnu-guix-1088744d8748a4ed81accdacab95eb397de0f23b.tar.gz
gnu: Add r-sna.
* gnu/packages/cran.scm (r-sna): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e06eb60e94..2e229e9e0f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2265,3 +2265,27 @@ supports arbitrary vertex/edge/graph attributes.")
(description "This package provides non-statistical utilities used by the
software developed by the Statnet Project.")
(license license:gpl3)))
+
+(define-public r-sna
+ (package
+ (name "r-sna")
+ (version "2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sna" version))
+ (sha256
+ (base32
+ "1ks8819qvpdfansfqj9p32s1rhvl26frvbi78m4rx1wd1qcv74i2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-network" ,r-network)
+ ("r-statnet-common" ,r-statnet-common)))
+ (home-page "http://www.statnet.org")
+ (synopsis "Tools for social network analysis")
+ (description
+ "This package provides a range of tools for social network analysis,
+including node and graph-level indices, structural distance and covariance
+methods, structural equivalence detection, network regression, random graph
+generation, and 2D/3D network visualization.")
+ (license license:gpl2+)))