summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-02-06 10:35:12 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-02-06 12:04:19 +0100
commit89c57efd788b6c72939977ad9122b91e557cab6d (patch)
treeb2e24ff96bfc6387f8af71f76719b1682b748938
parente9e78d2cec26687047c3efc703c6a344065a3cec (diff)
downloadgnu-guix-89c57efd788b6c72939977ad9122b91e557cab6d.tar
gnu-guix-89c57efd788b6c72939977ad9122b91e557cab6d.tar.gz
gnu: Add python-whatever.
* gnu/packages/python.scm (python-whatever, python2-whatever): New variables.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d789fcfee5..7838207762 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12448,3 +12448,34 @@ files, and Makefiles.")
(define-public python2-gyp
(package-with-python2 python-gyp))
+
+(define-public python-whatever
+ (package
+ (name "python-whatever")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Suor/whatever/archive/" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1iqvnaf0zpc6b4rvbqq4xy45mszcscyzpzknv8wg6j84pbp22sap"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "py.test"))))))
+ (native-inputs
+ `(("python-pytest-3.0" ,python-pytest-3.0)))
+ (home-page "http://github.com/Suor/whatever")
+ (synopsis "Make anonymous functions by partial application of operators")
+ (description "@code{whatever} provides an easy way to make anonymous
+functions by partial application of operators.")
+ (license license:bsd-3)))
+
+(define-public python2-whatever
+ (package-with-python2 python-whatever))