summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-05 18:41:33 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-06 16:12:50 +0100
commit4e847986bcdbcd7ac18c82b045b942e203332869 (patch)
tree888305f35214a9228877e78867f92f373b11c328
parent924b96db0aecc9f0b0bcd21165b5d5ea47199e29 (diff)
downloadgnu-guix-4e847986bcdbcd7ac18c82b045b942e203332869.tar
gnu-guix-4e847986bcdbcd7ac18c82b045b942e203332869.tar.gz
gnu: libssh: Update to commit 239d0f7 of branch 'v0-7'.
* gnu/packages/ssh.scm (libssh): Update to 239d0f7.
-rw-r--r--gnu/packages/ssh.scm59
1 files changed, 32 insertions, 27 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 793dcf8dc5..b439094c26 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
@@ -62,35 +62,40 @@
#:use-module (srfi srfi-1))
(define-public libssh
- (package
- (name "libssh")
- (version "0.7.5")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://red.libssh.org/attachments/download/218/libssh-"
- version ".tar.xz"))
- (sha256
- (base32
- "15bh6dm9c50ndddzh3gqcgw7axp3ghrspjpkb1z3dr90vkanvs2l"))
- (patches (search-patches "libssh-hostname-parser-bug.patch"))))
- (build-system cmake-build-system)
- (outputs '("out" "debug"))
- (arguments
- '(#:configure-flags '("-DWITH_GCRYPT=ON")
-
- ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
- #:tests? #f))
- (inputs `(("zlib" ,zlib)
- ("libgcrypt" ,libgcrypt)))
- (synopsis "SSH client library")
- (description
- "libssh is a C library implementing the SSHv2 and SSHv1 protocol for
+ ;; This commit from the 'v0-7' branch contains 7 memory-management-related
+ ;; bug fixes that we'd rather have.
+ (let ((commit "239d0f75b5f909174c2ef7fb08d23bcfa6b20ba0")
+ (revision "0"))
+ (package
+ (name "libssh")
+ (version (git-version "0.7.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.libssh.org/projects/libssh.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "01w72w1jsgs9ilj3n1gp6qkmdxr9n74i5h2nipi3x1vzm7bv8na1"))
+ (patches (search-patches "libssh-hostname-parser-bug.patch"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (outputs '("out" "debug"))
+ (arguments
+ '(#:configure-flags '("-DWITH_GCRYPT=ON")
+
+ ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
+ #:tests? #f))
+ (inputs `(("zlib" ,zlib)
+ ("libgcrypt" ,libgcrypt)))
+ (synopsis "SSH client library")
+ (description
+ "libssh is a C library implementing the SSHv2 and SSHv1 protocol for
client and server implementations. With libssh, you can remotely execute
programs, transfer files, and use a secure and transparent tunnel for your
remote applications.")
- (home-page "https://www.libssh.org")
- (license license:lgpl2.1+)))
+ (home-page "https://www.libssh.org")
+ (license license:lgpl2.1+))))
(define-public libssh2
(package