summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-02-06 12:08:00 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-02-06 12:10:17 +0100
commit4283653cb02d67de186fc632e88eed74587e8546 (patch)
tree20a7d081ee6e89f043c47bf3b22457aeccffaf3d
parent7e2dd00bfb2d1a5522bb35d876f2a0344034df48 (diff)
downloadgnu-guix-4283653cb02d67de186fc632e88eed74587e8546.tar
gnu-guix-4283653cb02d67de186fc632e88eed74587e8546.tar.gz
gnu: Add python-isoweek.
* gnu/packages/python.scm (python-isoweek, python2-isoweek): New variables. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a6de4550fd..777590b583 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12532,3 +12532,26 @@ Examples are:
(define-public python2-funcy
(package-with-python2 python-funcy))
+
+(define-public python-isoweek
+ (package
+ (name "python-isoweek")
+ (version "1.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "isoweek" version))
+ (sha256
+ (base32
+ "1s7zsf0pab0l9gn6456qadnz5i5h90hafcjwnhx5mq23qjxggwvk"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/gisle/isoweek")
+ (synopsis "Objects representing a week")
+ (description "The @code{isoweek} module provide the class Week that
+implements the week definition of ISO 8601. This standard also defines
+a notation for identifying weeks; yyyyWww (where the W is a literal).
+Week instances stringify to this form.")
+ (license license:bsd-3)))
+
+(define-public python2-isoweek
+ (package-with-python2 python-isoweek))