summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-08-23 13:33:22 +0200
committerLeo Famulari <leo@famulari.name>2018-08-23 16:26:40 -0400
commit87b576aa8ba6befefde8b700e4ec6cc953514348 (patch)
tree98b46641f60741697529cf60957dc2d2cd247502
parentc994418b8c33b4f0642062cd3ef743da90e53bf6 (diff)
downloadgnu-guix-87b576aa8ba6befefde8b700e4ec6cc953514348.tar
gnu-guix-87b576aa8ba6befefde8b700e4ec6cc953514348.tar.gz
gnu: Add r-slam.
gnu/packages/cran.scm (r-slam): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/cran.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8ee1fbfb9e..7271279a2a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4872,3 +4872,21 @@ of losing information from a data set. This package provides tools to calculate
these limits on the basis of the mathematical properties of the distribution of
the analyzed items.")
(license license:gpl3)))
+
+(define-public r-slam
+ (package
+ (name "r-slam")
+ (version "0.1-43")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "slam" version))
+ (sha256
+ (base32 "0hy4qzngcgafxxr6ld7n9a9wy979ji998gpcc32vidwyab66dj5h"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/slam/")
+ (synopsis "Sparse lightweight arrays and matrices")
+ (description
+ "This package contains data structures and algorithms for sparse arrays and matrices,
+based on index arrays and simple triplet representations, respectively.")
+ (license license:gpl2)))