summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-04-19 20:50:23 +0100
committerChristopher Baines <christopher.baines@digital.cabinet-office.gov.uk>2020-05-23 22:57:12 +0100
commit879b66343e4168e4cf40dd4bcb109b17dac9c391 (patch)
tree9e403f07be75f7b17a8f10e576d9f168d972f187
parenta741a1d9f2e1dd7fedf6d602f22da38e82d9b4e6 (diff)
downloadgnu-guix-879b66343e4168e4cf40dd4bcb109b17dac9c391.tar
gnu-guix-879b66343e4168e4cf40dd4bcb109b17dac9c391.tar.gz
gnu: Add packer.
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c6f47aa144..ca34b3138d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2486,6 +2486,28 @@ as conversion to and from @command{net.Addr}.")
(description "Tar utilities extracted from @command{go-ipfs} codebase.")
(license license:expat))))
+(define-public packer
+ (package
+ (name "packer")
+ (version "1.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/packer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fpzmwh7vq8vc7gvlnpx4ji4yaxwi2h2ksz0z4782469pkcnbg56"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hashicorp/packer"))
+ (synopsis "")
+ (description
+ "")
+ (home-page "https://www.terraform.io/")
+ (license license:mpl2.0)))
+
(define-public go-github-com-cheekybits-is
(let ((commit "68e9c0620927fb5427fda3708222d0edee89eae9")
(revision "0"))