summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-12 20:04:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-13 22:50:43 +0200
commit49604680cd2574a199eb0143ee3a49425a5e14f1 (patch)
tree7f4e0afbf58412bf8c27e6db7cf98428408a802d
parent71d3ee1cbbccdf984c8f53d4b9596a4e06489769 (diff)
downloadgnu-guix-49604680cd2574a199eb0143ee3a49425a5e14f1.tar
gnu-guix-49604680cd2574a199eb0143ee3a49425a5e14f1.tar.gz
gnu: Add gx-guvnor-lv2.
* gnu/packages/music.scm (gx-guvnor-lv2): New variable.
-rw-r--r--gnu/packages/music.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4539339bf8..cb13f9a324 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1965,3 +1965,43 @@ CSV file in the format created by midicsv may be converted back into a
standard MIDI file with the csvmidi program.")
(home-page "http://www.fourmilab.ch/webtools/midicsv/")
(license license:public-domain)))
+
+(define-public gx-guvnor-lv2
+ (let ((commit "9f528a7623a201383e119bb6a2df32b18396a9d5")
+ (revision "1"))
+ (package
+ (name "gx-guvnor-lv2")
+ (version (string-append "0-" revision "." (string-take commit 9)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brummer10/GxGuvnor.lv2")
+ (commit commit)))
+ (sha256
+ (base32
+ "10zx84p2vd7i1yqc5ma9p17927265j4g0zfwv9rxladw0nm8y45k"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(;; The check target is used only to output a warning.
+ #:tests? #f
+ #:make-flags
+ (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* "Makefile"
+ (("INSTALL_DIR = .*") "INSTALL_DIR=/lib/lv2\n")
+ ;; Avoid rebuilding everything
+ (("install : all") "install:"))
+ #t)))))
+ (inputs
+ `(("lv2" ,lv2)))
+ (home-page "https://github.com/brummer10/GxGuvnor.lv2")
+ (synopsis "Overdrive/distortion pedal simulation")
+ (description "This package provides the LV2 plugin \"GxGuvnor\", a
+simulation of an overdrive or distortion pedal for guitars.")
+ ;; The LICENSE file says GPLv3 but the license headers in the files say
+ ;; GPLv2 or later.
+ (license license:gpl2+))))