summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 02:28:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-30 03:46:20 +0200
commitb414cf523bcb90182403e7cf79aa7093c272eacf (patch)
tree9a2e8358660f0ff3e8315534df544f6db361d9d7
parente02a9975b8d8cc444c6b76483365cc4e2b8d76f9 (diff)
downloadgnu-guix-b414cf523bcb90182403e7cf79aa7093c272eacf.tar
gnu-guix-b414cf523bcb90182403e7cf79aa7093c272eacf.tar.gz
gnu: mumps: Use INVOKE.
* gnu/packages/maths.scm (mumps)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/maths.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cfb4b6f632..8b4034a12e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1911,8 +1911,8 @@ IORDERINGSC = $(IPORD) $(IMETIS) $(ISCOTCH)"
;; By default only the d-precision library is built. Make with "all"
;; target so that all precision libraries and examples are built.
(lambda _
- (zero? (system* "make" "all"
- (format #f "-j~a" (parallel-job-count))))))
+ (invoke "make" "all"
+ (format #f "-j~a" (parallel-job-count)))))
(replace 'check
;; Run the simple test drivers, which read test input from stdin:
;; from the "real" input for the single- and double-precision