summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-06-29 10:55:00 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-06-29 11:08:09 -0400
commit529701aa013e645221c4258cfcd4df096876162e (patch)
tree0598dae7f1c5a82635eab8fde2379bac6abdbbf1
parent12a96d4d419330056d647817aa09f02f031cba6f (diff)
downloadgnu-guix-529701aa013e645221c4258cfcd4df096876162e.tar
gnu-guix-529701aa013e645221c4258cfcd4df096876162e.tar.gz
gnu: cataclysm-dda: Update snapshot.
* gnu/packages/games.scm (cataclysm-dda): Update snapshot to ad3b0c3d5. [source]: Use git-fetch and remove snippet. [arguments]: Remove 'configure' phase. Use 'invoke' in 'build-tiles' and 'install-tiles' phases.
-rw-r--r--gnu/packages/games.scm140
1 files changed, 64 insertions, 76 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2ced2b51da..5f43aa154c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -177,82 +177,70 @@ settings to tweak as well.")
(license license:gpl2+)))
(define-public cataclysm-dda
- (package
- (name "cataclysm-dda")
- (version "0.C")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/CleverRaven/Cataclysm-DDA/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1xlajmgl9cviqyjpp5g5q4rbljy9gqc49v54bi8gpzr68s14gsb9"))
- (modules '((guix build utils)))
- (snippet
- ;; Import cmath header for the std::pow function.
- '(begin
- (for-each (lambda (file)
- (substitute* file
- (("#include <math.h>")
- "#include <cmath>")))
- (find-files "src"))
- #t))))
- (build-system gnu-build-system)
- (arguments
- '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "USE_HOME_DIR=1" "DYNAMIC_LINKING=1" "RELEASE=1")
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (substitute* "Makefile"
- (("ncursesw5-config") "ncursesw6-config")
- (("RELEASE_FLAGS = -Werror") "RELEASE_FLAGS ="))
- #t))
- (add-after 'build 'build-tiles
- (lambda* (#:key make-flags outputs #:allow-other-keys)
- ;; Change prefix directory and enable tile graphics and sound.
- (zero?
- (apply system* "make" "TILES=1" "SOUND=1"
- (string-append "PREFIX="
- (assoc-ref outputs "tiles"))
- (cdr make-flags)))))
- (add-after 'install 'install-tiles
- (lambda* (#:key make-flags outputs #:allow-other-keys)
- (zero?
- (apply system* "make" "install" "TILES=1" "SOUND=1"
- (string-append "PREFIX="
- (assoc-ref outputs "tiles"))
- (cdr make-flags))))))
- ;; TODO: Add libtap++ from https://github.com/cbab/libtappp as a native
- ;; input in order to support tests.
- #:tests? #f))
- (outputs '("out"
- "tiles")) ; For tile graphics and sound support.
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("freetype" ,freetype)
- ("libogg" ,libogg)
- ("libvorbis" ,libvorbis)
- ("ncurses" ,ncurses)
- ("sdl2" ,sdl2)
- ("sdl2-image" ,sdl2-image)
- ("sdl2-ttf" ,sdl2-ttf)
- ("sdl2-mixer" ,sdl2-mixer)))
- (home-page "http://en.cataclysmdda.com/")
- (synopsis "Survival horror roguelike video game")
- (description
- "Cataclysm: Dark Days Ahead is a roguelike set in a post-apocalyptic world.
-Struggle to survive in a harsh, persistent, procedurally generated world.
-Scavenge the remnants of a dead civilization for food, equipment, or, if you are
-lucky, a vehicle with a full tank of gas to get you out of Dodge. Fight to
-defeat or escape from a wide variety of powerful monstrosities, from zombies to
-giant insects to killer robots and things far stranger and deadlier, and against
-the others like yourself, that want what you have.")
- (license license:cc-by-sa3.0)))
+ (let ((commit "ad3b0c3d521292d119f97a83390e7acfe9e9e7f7")
+ (revision "1"))
+ (package
+ (name "cataclysm-dda")
+ ;; This denotes the version released after the 0.C release.
+ ;; Revert to a normal version number if updating to stable version 0.D.
+ (version (git-version "0.C" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CleverRaven/Cataclysm-DDA.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1kdgbl8zqd53f5yilm2c9nyq3w6585yxl5jvgxy65dlpzxcqqj7y"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "USE_HOME_DIR=1" "DYNAMIC_LINKING=1" "RELEASE=1")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'build 'build-tiles
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ ;; Change prefix directory and enable tile graphics and sound.
+ (apply invoke "make" "TILES=1" "SOUND=1"
+ (string-append "PREFIX="
+ (assoc-ref outputs "tiles"))
+ (cdr make-flags))))
+ (add-after 'install 'install-tiles
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (apply invoke "make" "install" "TILES=1" "SOUND=1"
+ (string-append "PREFIX="
+ (assoc-ref outputs "tiles"))
+ (cdr make-flags)))))
+ ;; TODO: Add libtap++ from https://github.com/cbab/libtappp as a native
+ ;; input in order to support tests.
+ #:tests? #f))
+ (outputs '("out"
+ "tiles")) ; For tile graphics and sound support.
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("libogg" ,libogg)
+ ("libvorbis" ,libvorbis)
+ ("ncurses" ,ncurses)
+ ("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("sdl2-ttf" ,sdl2-ttf)
+ ("sdl2-mixer" ,sdl2-mixer)))
+ (home-page "http://en.cataclysmdda.com/")
+ (synopsis "Survival horror roguelike video game")
+ (description
+ "Cataclysm: Dark Days Ahead is a roguelike set in a post-apocalyptic
+world. Struggle to survive in a harsh, persistent, procedurally generated
+world. Scavenge the remnants of a dead civilization for food, equipment, or,
+if you are lucky, a vehicle with a full tank of gas to get you out of Dodge.
+Fight to defeat or escape from a wide variety of powerful monstrosities, from
+zombies to giant insects to killer robots and things far stranger and deadlier,
+and against the others like yourself, that want what you have.")
+ (license license:cc-by-sa3.0))))
(define-public cowsay
(package