summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 11:16:12 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:44 +0000
commitf7d073140b9b4920c5351cb209b3f593cfea98a7 (patch)
treecf977f50f031e713b885fe57937da56615ec2af7
parentbc807166815b03355112c0ba22a7992146da03be (diff)
downloadgnu-guix-f7d073140b9b4920c5351cb209b3f593cfea98a7.tar
gnu-guix-f7d073140b9b4920c5351cb209b3f593cfea98a7.tar.gz
gnu: Add ruby-open4.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 59ba1fa3b2..547759e237 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8604,3 +8604,24 @@ but it can function as a stand-alone templating engine.")
(home-page
"http://github.com/brianmario/bzip2-ruby")
(license #f))))
+
+(define-public ruby-open4
+ (package
+ (name "ruby-open4")
+ (version "1.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "open4" version))
+ (sha256
+ (base32
+ "1cgls3f9dlrpil846q0w7h66vsc33jqn84nql4gcqkk221rh7px1"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
+ (description
+ "open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
+ (home-page "https://github.com/ahoward/open4")
+ (license #f)))