summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:45 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:46:23 +0000
commitf7c4b57ca472faa1776b8a55e0f8019faed22ca2 (patch)
tree0554534d9d3d8bb6f89fef367fe5543cae659fdd
parente23cdb1a43ea9b56a971db3ae375e6eff406cec1 (diff)
downloadgnu-guix-f7c4b57ca472faa1776b8a55e0f8019faed22ca2.tar
gnu-guix-f7c4b57ca472faa1776b8a55e0f8019faed22ca2.tar.gz
gnu: Add ruby-ruby-progressbar.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9bbc7cacbf..e860a0748f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2572,6 +2572,34 @@ rate.")
(home-page "https://github.com/paul/progress_bar")
(license license:wtfpl2)))
+(define-public ruby-ruby-progressbar
+ (package
+ (name "ruby-ruby-progressbar")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby-progressbar" version))
+ (sha256
+ (base32
+ "1igh1xivf5h5g3y5m9b4i4j2mhz2r43kngh4ww3q1r80ch21nbfk"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests require further dependencies such as 'rspectacular'.
+ (synopsis
+ "Ruby/ProgressBar is an extremely flexible text progress bar library for Ruby.
+The output can be customized with a flexible formatting system including:
+percentage, bars of various formats, elapsed time and estimated time remaining.
+")
+ (description
+ "Ruby/ProgressBar is an extremely flexible text progress bar library for Ruby.
+The output can be customized with a flexible formatting system including:
+percentage, bars of various formats, elapsed time and estimated time remaining.
+")
+ (home-page
+ "https://github.com/jfelchner/ruby-progressbar")
+ (license license:expat)))
+
(define-public ruby-pry
(package
(name "ruby-pry")