summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-28 01:14:34 +0100
committerLudovic Courtès <ludo@gnu.org>2014-10-28 01:18:50 +0100
commitf47638a3534c99fb8fef501c5827e9e32a6b4a2e (patch)
tree4611841beeff27a83c78b98f776fdcf1a574e789
parent2d7bf949277a0889ced8aa486c4ef16cb7cf6b1a (diff)
downloadgnu-guix-f47638a3534c99fb8fef501c5827e9e32a6b4a2e.tar
gnu-guix-f47638a3534c99fb8fef501c5827e9e32a6b4a2e.tar.gz
gnu: Mark a few packages as unsupported on MIPS.
* gnu/packages/gprolog.scm (gprolog): Add 'supported-systems' field. * gnu/packages/qemu.scm (qemu-headless): Likewise. * gnu/packages/qt.scm (qt): Likewise. * gnu/packages/scheme.scm (racket): Likewise.
-rw-r--r--gnu/packages/gprolog.scm5
-rw-r--r--gnu/packages/qemu.scm5
-rw-r--r--gnu/packages/qt.scm7
-rw-r--r--gnu/packages/scheme.scm6
4 files changed, 19 insertions, 4 deletions
diff --git a/gnu/packages/gprolog.scm b/gnu/packages/gprolog.scm
index de323da57c..8c41bf4682 100644
--- a/gnu/packages/gprolog.scm
+++ b/gnu/packages/gprolog.scm
@@ -52,4 +52,7 @@
solving over finite domains. It accepts Prolog+ constraint programs and
produces a compiled, native binary which can function in a stand-alone
manner. It also features an interactive interpreter.")
- (license (list gpl2+ lgpl3+))))
+ (license (list gpl2+ lgpl3+))
+
+ ;; See 'configure' for the list of supported architectures.
+ (supported-systems (delete "mips64el-linux" %supported-systems))))
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 33d23572bd..75a14b6e8f 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -125,7 +125,10 @@ the KVM kernel module in Linux. When using KVM, QEMU can virtualize x86,
server and embedded PowerPC, and S390 guests.")
;; Many files are GPLv2+, but some are GPLv2-only---e.g., `memory.c'.
- (license gpl2)))
+ (license gpl2)
+
+ ;; Several tests fail on MIPS; see <http://hydra.gnu.org/build/117914>.
+ (supported-systems (delete "mips64el-linux" %supported-systems))))
(define-public qemu
;; QEMU with GUI support.
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 3df0066c4f..391cfac77e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -145,7 +145,12 @@ X11 (yet).")
(synopsis "Cross-platform GUI library")
(description "Qt is a cross-platform application and UI framework for
developers using C++ or QML, a CSS & JavaScript like language.")
- (license lgpl2.1)))
+ (license lgpl2.1)
+
+ ;; Qt 4: 'QBasicAtomicPointer' leads to build failures on MIPS;
+ ;; see <http://hydra.gnu.org/build/112828>.
+ ;; Qt 5: assembler error; see <http://hydra.gnu.org/build/112526>.
+ (supported-systems (delete "mips64el-linux" %supported-systems))))
(define-public qt-4
(package (inherit qt)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 8e4f6ae3ec..40ea5b930c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -422,4 +422,8 @@ implementation techniques and as an expository tool.")
R6RS) and related languages, such as Typed Racket. It features a compiler and
a virtual machine with just-in-time native compilation, as well as a large set
of libraries.")
- (license lgpl2.0+)))
+ (license lgpl2.0+)
+
+ ;; Fails to build on MIPS with "address or size is not OS PAGE ALIGNED".
+ ;; See <http://hydra.gnu.org/build/121775>.
+ (supported-systems (delete "mips64el-linux" %supported-systems))))