summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2017-09-06 12:51:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2017-09-06 12:51:59 +0200
commitf049e79dc34c112fca244946256920a5ce2e9db0 (patch)
tree8aba1bcbaae63b91f0da250c66cdc8eacc439d23
parent026ebc141ff9eb6147c9538f004119193d4cfe49 (diff)
downloadgnu-guix-f049e79dc34c112fca244946256920a5ce2e9db0.tar
gnu-guix-f049e79dc34c112fca244946256920a5ce2e9db0.tar.gz
gnu: csound: Update to 6.09.1.
* gnu/packages/audio.scm (csound): Update to 6.09.1. Change source URI. * gnu/packages/patches/csound-header-ordering.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Remove reference to patch above.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/audio.scm16
-rw-r--r--gnu/packages/patches/csound-header-ordering.patch20
3 files changed, 5 insertions, 32 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 73efaba64e..2975c0208e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -566,7 +566,6 @@ dist_patch_DATA = \
%D%/packages/patches/crawl-upgrade-saves.patch \
%D%/packages/patches/crda-optional-gcrypt.patch \
%D%/packages/patches/crossmap-allow-system-pysam.patch \
- %D%/packages/patches/csound-header-ordering.patch \
%D%/packages/patches/clucene-contribs-lib.patch \
%D%/packages/patches/curl-bounds-check.patch \
%D%/packages/patches/cursynth-wave-rand.patch \
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e27c13bed4..1b7950cf00 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -568,23 +568,17 @@ emulation (valve, tape), bit fiddling (decimator, pointer-cast), etc.")
(define-public csound
(package
(name "csound")
- (version "6.05")
+ (version "6.09.1")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://sourceforge/csound/csound6/Csound"
- version "/Csound" version ".tar.gz"))
+ "https://github.com/csound/csound/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0a1sni6lr7qpwywpggbkp0ia3h9bwwgf9i87gsag8ra2h30v82hd"))
- (patches (search-patches "csound-header-ordering.patch"))))
+ "0f67vyy3r29hn26qkkcwnizrnzzy8p7gmg3say5q3wjhxns3b5yl"))))
(build-system cmake-build-system)
- (arguments
- ;; Work around this error on x86_64 with libc 2.22+:
- ;; libmvec.so.1: error adding symbols: DSO missing from command line
- (if (string-prefix? "x86_64" (or (%current-target-system) (%current-system)))
- '(#:configure-flags '("-DCMAKE_EXE_LINKER_FLAGS=-lmvec"))
- '()))
(inputs
`(("alsa-lib" ,alsa-lib)
("boost" ,boost)
diff --git a/gnu/packages/patches/csound-header-ordering.patch b/gnu/packages/patches/csound-header-ordering.patch
deleted file mode 100644
index 3640d123dd..0000000000
--- a/gnu/packages/patches/csound-header-ordering.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Prevent compilation issues with boost-1.60.0.
-
-Reported upstream at https://github.com/csound/csound/issues/570
-
---- Csound6.05/Opcodes/chua/ChuaOscillator.cpp 2015-04-25 14:06:22.995646234 -0500
-+++ Csound6.05/Opcodes/chua/ChuaOscillator.cpp 2015-12-21 10:31:58.182362640 -0600
-@@ -117,11 +117,12 @@
- // d = sys_variables(12);
- // gnor = a*(x.^3) + b*(x.^2) + c*x + d;
-
--#include <OpcodeBase.hpp>
- #include <boost/numeric/ublas/vector.hpp>
- using namespace boost::numeric;
- #include <cmath>
-
-+#include <OpcodeBase.hpp>
-+
- #undef CS_KSMPS
- #define CS_KSMPS (opds.insdshead->ksmps)
-