summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:41 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commiteffedefc063458776bd1121d3dd9bfbe99bff970 (patch)
treea69a4de06e8f28f4258b7995b2cc0501a2658306
parentc03a17db9d4b6c34b62588f07417f4367d3ae127 (diff)
downloadgnu-guix-effedefc063458776bd1121d3dd9bfbe99bff970.tar
gnu-guix-effedefc063458776bd1121d3dd9bfbe99bff970.tar.gz
gnu: Add ruby-omniauth.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 87707ff421..79fa580177 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8886,3 +8886,28 @@ but it can function as a stand-alone templating engine.")
"This package provides a Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
(home-page "http://github.com/intridea/oauth2")
(license license:expat)))
+
+(define-public ruby-omniauth
+ (package
+ (name "ruby-omniauth")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth" version))
+ (sha256
+ (base32
+ "1msqr4qq7mfdvl3rg89529isrv595hvjpj2gi0say4b8nwqfggmg"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-hashie" ,ruby-hashie)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A generalized Rack framework for multiple-provider authentication.")
+ (description
+ "This package provides a generalized Rack framework for multiple-provider authentication.")
+ (home-page
+ "https://github.com/omniauth/omniauth")
+ (license license:expat)))