summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-19 23:28:13 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-18 22:16:37 +0100
commiteffc8325a5c1aa07ca6cf13e864010ea67d24898 (patch)
tree03a535058058d114ee113fde6ba75565224caf1a
parent6e8986c8388e889eb74509999aea826fd440dcc4 (diff)
downloadgnu-guix-effc8325a5c1aa07ca6cf13e864010ea67d24898.tar
gnu-guix-effc8325a5c1aa07ca6cf13e864010ea67d24898.tar.gz
gnu: ocaml-migrate-parsetree: Use dune-build-system.
* gnu/packages/ocaml.scm (ocaml-migrate-parsetree): Use dune-build-system.
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7ba5a6b4f9..ed087b7298 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -63,6 +63,7 @@
#:use-module (gnu packages web-browsers)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (guix build-system dune)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ocaml)
#:use-module (guix download)
@@ -1564,26 +1565,13 @@ following a very simple s-expression syntax.")
(sha256
(base32
"01zjp1q4hryqaxv4apkjd868fycz2kf887r6lkb6x2a545h1lh7f"))))
- (build-system ocaml-build-system)
+ (build-system dune-build-system)
(arguments
`(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda _
- (invoke "jbuilder" "build" "@install")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "jbuilder" "install"
- "--prefix" (assoc-ref outputs "out"))
- #t)))))
+ #:jbuild? #t))
(propagated-inputs
`(("ocamlbuild" ,ocamlbuild)
("ocaml-result" ,ocaml-result)))
- (native-inputs
- `(("dune" ,dune)))
(home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
(synopsis "OCaml parsetree convertor")
(description "This library converts between parsetrees of different OCaml