summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-28 00:52:05 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-28 00:52:05 +0200
commitd22d72fc50ee16bcb945382c2d2797ef45bdfbbd (patch)
treedf400dc930f9685f687943041d2b8b1c787ddd3a
parent274da61d515ee60c893d9eea3daab35d4a97f6b5 (diff)
downloadgnu-guix-d22d72fc50ee16bcb945382c2d2797ef45bdfbbd.tar
gnu-guix-d22d72fc50ee16bcb945382c2d2797ef45bdfbbd.tar.gz
gnu: Add perl-www-curl.
* gnu/packages/web.scm (perl-www-curl): New variable.
-rw-r--r--gnu/packages/web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 57eb89adfc..86e250126f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages openssl)
#:use-module (gnu packages pcre)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages perl))
(define-public httpd
@@ -547,3 +548,26 @@ solution for use cases such as embedded deployments where a full featured HTTP
proxy is required, but the system resources for a larger proxy are
unavailable.")
(license l:gpl2+)))
+
+(define-public perl-www-curl
+ (package
+ (name "perl-www-curl")
+ (version "4.17")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SZ/SZBALINT/WWW-Curl-"
+ version".tar.gz"))
+ (sha256
+ (base32
+ "1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:tests? #f)) ;XXX: tests require network access
+ (inputs `(("curl" ,curl)))
+ (synopsis "Perl extension interface for libcurl")
+ (description
+ "This is a Perl extension interface for the libcurl file downloading
+library.")
+ (license (package-license perl))
+ (home-page "http://search.cpan.org/~szbalint/WWW-Curl-4.17/lib/WWW/Curl.pm")))