summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-10-14 02:52:41 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2018-11-19 12:02:26 +0100
commitd0ad97115abb548195b920e83ce2769b5020884d (patch)
treea0689f0445dbdc46d808ddfd008b5d1b6b25e862
parent8da9187a5a2477e3e7114e5a25ae8ae57bf73271 (diff)
downloadgnu-guix-d0ad97115abb548195b920e83ce2769b5020884d.tar
gnu-guix-d0ad97115abb548195b920e83ce2769b5020884d.tar.gz
gnu: clojure: Use (guix build java-utils) to simplify build phases.
* gnu/packages/lisp.scm (clojure)[arguments]: Use 'ant-build-javadoc', 'install-jars' and 'install-javadoc' in build phases.
-rw-r--r--gnu/packages/lisp.scm24
1 files changed, 6 insertions, 18 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 24738f3f13..c33e4187c7 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -614,10 +614,10 @@ interface.")
(build-system ant-build-system)
(arguments
`(#:modules ((guix build ant-build-system)
+ (guix build java-utils)
(guix build utils)
(ice-9 ftw)
(ice-9 regex)
- (srfi srfi-1)
(srfi srfi-26))
#:test-target "test"
#:phases
@@ -641,34 +641,22 @@ interface.")
(substitute* "build.xml"
(("<attribute name=\"Class-Path\" value=\".\"/>") ""))
#t))
- ;; The javadoc target is not built by default.
- (add-after 'build 'build-doc
- (lambda _
- (invoke "ant" "javadoc")))
- ;; Needed since no install target is provided.
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((java-dir (string-append (assoc-ref outputs "out")
- "/share/java/")))
- ;; Install versioned to avoid collisions.
- (install-file (string-append "clojure-" ,version ".jar")
- java-dir)
- #t)))
- ;; Needed since no install-doc target is provided.
+ (add-after 'build 'build-javadoc ant-build-javadoc)
+ (replace 'install (install-jars "./"))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let ((doc-dir (string-append (assoc-ref outputs "out")
"/share/doc/clojure-"
,version "/")))
(copy-recursively "doc/clojure" doc-dir)
- (copy-recursively "target/javadoc/"
- (string-append doc-dir "javadoc/"))
(for-each (cut install-file <> doc-dir)
(filter (cut string-match
".*\\.(html|markdown|md|txt)"
<>)
(scandir "./")))
- #t))))))
+ #t)))
+ (add-after 'install-doc 'install-javadoc
+ (install-javadoc "target/javadoc/")))))
(native-inputs libraries)
(home-page "https://clojure.org/")
(synopsis "Lisp dialect running on the JVM")