summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:04:16 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:46:23 +0000
commitcf16fccfc9568a055e785d429322ed62a11021d9 (patch)
tree67452044bee7cedd1aa4edb0b496063b9341680f
parent9e81171ca5d2ae41fa59522be35f9dafbc9c23b8 (diff)
downloadgnu-guix-cf16fccfc9568a055e785d429322ed62a11021d9.tar
gnu-guix-cf16fccfc9568a055e785d429322ed62a11021d9.tar.gz
gnu: Add ruby-rspec-spies.
-rw-r--r--gnu/packages/ruby.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2b2f1b586b..90e76e1858 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -346,6 +346,42 @@ notebook).")
(home-page "https://github.com/SciRuby/iruby")
(license license:expat)))
+(define-public ruby-rspec-spies
+ (package
+ (name "ruby-rspec-spies")
+ (version "2.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rspec-spies" version))
+ (sha256
+ (base32
+ "0pyjy35k59gsiv7l8585yx4gkg2vhycjycz9jlmgkx8s62dxnjgv"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests fail, is this completely deprecated?
+ ;; phases
+ ;; (modify-phases %standard-phases
+ ;; (replace 'check
+ ;; (lambda _
+ ;; (zero? (system* "rspec"))))
+ ;; (add-before 'check 'fix-dependencies
+ ;; (lambda _
+ ;; (delete-file "Gemfile.lock")
+ ;; (substitute* "Gemfile"
+ ;; ((".*jeweler.*") "\n"))
+ ;; #t)))))
+ ;; (native-inputs
+ ;; `(("bundler" ,bundler)
+ ;; ("ruby-appraisal" ,ruby-appraisal)))
+ (propagated-inputs
+ `(("ruby-rspec" ,ruby-rspec-2)))
+ (synopsis "test spies, for rspec")
+ (description "test spies, for rspec")
+ (home-page
+ "http://github.com/technicalpickles/rspec-spies")
+ (license #f)))
+
;; RSpec is the dominant testing library for Ruby projects. Even RSpec's
;; dependencies use RSpec for their test suites! To avoid these circular
;; dependencies, we disable tests for all of the RSpec-related packages.