summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:56:16 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:53 +0000
commitc7f97657d3c9152f42dd00f94c6d9ec4a1391b2e (patch)
treecc5177f430115a8439fa227c7d03ad5ce21749fa
parentabaa5df9b614b83a0177ea84881524936614b6f9 (diff)
downloadgnu-guix-c7f97657d3c9152f42dd00f94c6d9ec4a1391b2e.tar
gnu-guix-c7f97657d3c9152f42dd00f94c6d9ec4a1391b2e.tar.gz
gnu: Add python-html-linter.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 508c269d40..051ae50fd5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15415,3 +15415,27 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Remove the template markup from html files")
(license #f)))
+
+(define-public python-html-linter
+ (package
+ (name "python-html-linter")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "html-linter" version))
+ (sha256
+ (base32
+ "148ijk0hisb9b049xgc72gxdil3f0ichkpigasi11j1ggxkssb9l"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docopt" ,python-docopt)
+ ("python-template-remover" ,python-template-remover)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "http://github.com/sk-/html-linter")
+ (synopsis
+ "Lints an HTML5 file using Google's style guide")
+ (description
+ "Lints an HTML5 file using Google's style guide")
+ (license #f)))