summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:03:29 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:01:11 +0000
commitc7dae4c3b38fdf0de8eae7e2de29a068dd64abcb (patch)
tree0d09e2ecaf03d4193e494c5f6a016ac1cc0342fd
parent310df19f2d224f76c03a4e73a08ccf12647d2e77 (diff)
downloadgnu-guix-c7dae4c3b38fdf0de8eae7e2de29a068dd64abcb.tar
gnu-guix-c7dae4c3b38fdf0de8eae7e2de29a068dd64abcb.tar.gz
gnu: Add ruby-guard-rspec.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 675778b315..91b47dfa27 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8228,3 +8228,29 @@ but it can function as a stand-alone templating engine.")
"Helps creating valid Guard plugins and testing them")
(home-page "")
(license license:expat)))
+
+(define-public ruby-guard-rspec
+ (package
+ (name "ruby-guard-rspec")
+ (version "4.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "guard-rspec" version))
+ (sha256
+ (base32
+ "1jkm5xp90gm4c5s51pmf92i9hc10gslwwic6mvk72g0yplya0yx4"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests require further dependencies e.g. gem_isolator.
+ (propagated-inputs
+ `(("ruby-guard" ,ruby-guard)
+ ("ruby-guard-compat" ,ruby-guard-compat)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis
+ "Guard::RSpec automatically run your specs (much like autotest).")
+ (description
+ "Guard::RSpec automatically run your specs (much like autotest).")
+ (home-page
+ "https://github.com/guard/guard-rspec")
+ (license license:expat)))