summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-06-24 11:51:05 +1000
committerMark H Weaver <mhw@netris.org>2015-06-24 00:39:22 -0400
commitc684629f7c0cd9246ac395514e5b14ea118529cd (patch)
tree73f932f6a9edafdef854e381f49bf82e7659e901
parent5a72e4665aa3348957da93bd0b2ad839bfc4c328 (diff)
downloadgnu-guix-c684629f7c0cd9246ac395514e5b14ea118529cd.tar
gnu-guix-c684629f7c0cd9246ac395514e5b14ea118529cd.tar.gz
gnu: Add hmmer.
* gnu/packages/bioinformatics.scm (hmmer): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e1303364a3..31df2196dc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1032,6 +1032,35 @@ several alignment strategies enable effective alignment of RNA-seq reads, in
particular, reads spanning multiple exons.")
(license license:gpl3+)))
+(define-public hmmer
+ (package
+ (name "hmmer")
+ (version "3.1b2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://selab.janelia.org/software/hmmer"
+ (version-prefix version 1) "/"
+ version "/hmmer-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("perl", perl)))
+ (home-page "http://hmmer.janelia.org")
+ (synopsis "Biosequence analysis using profile hidden Markov models")
+ (description
+ "HMMER is used for searching sequence databases for homologs of protein
+sequences, and for making protein sequence alignments. It implements methods
+using probabilistic models called profile hidden Markov models (profile
+HMMs).")
+ (license (list license:gpl3+
+ ;; The bundled library 'easel' is distributed
+ ;; under The Janelia Farm Software License.
+ (license:non-copyleft
+ "file://easel/LICENSE"
+ "See easel/LICENSE in the distribution.")))))
+
(define-public htseq
(package
(name "htseq")