summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:33 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commitc03a17db9d4b6c34b62588f07417f4367d3ae127 (patch)
tree88b5b7202bb401149fc4d4913c79f68cc3d2598c
parentfa6cd57d5e4564f8633eb6dd3534f7b6c1002ad1 (diff)
downloadgnu-guix-c03a17db9d4b6c34b62588f07417f4367d3ae127.tar
gnu-guix-c03a17db9d4b6c34b62588f07417f4367d3ae127.tar.gz
gnu: Add ruby-oauth2.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 91aac9d3c6..87707ff421 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8859,3 +8859,30 @@ but it can function as a stand-alone templating engine.")
"This package provides a pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
(home-page "http://github.com/jwt/ruby-jwt")
(license license:expat)))
+
+(define-public ruby-oauth2
+ (package
+ (name "ruby-oauth2")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "oauth2" version))
+ (sha256
+ (base32
+ "094hmmfms8vpm6nwglpl7jmlv85nlfzl0kik4fizgx1rg70a6mr5"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-faraday" ,ruby-faraday)
+ ("ruby-jwt" ,ruby-jwt)
+ ("ruby-multi-json" ,ruby-multi-json)
+ ("ruby-multi-xml" ,ruby-multi-xml)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (description
+ "This package provides a Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
+ (home-page "http://github.com/intridea/oauth2")
+ (license license:expat)))