summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-01 16:15:27 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-02 00:09:17 +0100
commitb6f024ada7cb01660156ab552c4061fab8df63a9 (patch)
treec3e26e88fa6f924892d1ca3e8416b34b68b79a1b
parentd5960bf7c2273d77f76916cec24af9623a16e02c (diff)
downloadgnu-guix-b6f024ada7cb01660156ab552c4061fab8df63a9.tar
gnu-guix-b6f024ada7cb01660156ab552c4061fab8df63a9.tar.gz
gnu: Rename perl-zip to perl-archive-zip.
It's called Archive::Zip, after all. Bring it in line with other modules. * gnu/packages/compression.scm (perl-zip): Rename from this... (perl-archive-zip): ...to this. * gnu/packages/libreoffice.scm (libreoffice): Update the only caller.
-rw-r--r--gnu/packages/compression.scm4
-rw-r--r--gnu/packages/libreoffice.scm2
2 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 4948fd2d47..ae6710b25d 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1802,9 +1802,9 @@ recreates the stored directory structure by default.")
"ZZipLib is a library based on zlib for accessing zip files.")
(license license:lgpl2.0+)))
-(define-public perl-zip
+(define-public perl-archive-zip
(package
- (name "perl-zip")
+ (name "perl-archive-zip")
(version "1.60")
(source
(origin
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 6524e58400..799b062439 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -926,7 +926,7 @@ and to return information on pronunciations, meanings and synonyms.")
("openssl" ,openssl)
("orcus" ,orcus)
("perl" ,perl)
- ("perl-zip" ,perl-zip)
+ ("perl-archive-zip" ,perl-archive-zip)
("poppler" ,poppler)
("postgresql" ,postgresql)
("python" ,python)