summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-27 18:28:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-27 18:28:29 +0200
commitb651a5ab35414da54887780d03ea786ad4c894f2 (patch)
tree6793a2d06431d79d43406f22569ae4e086e413de
parent4053585e3f4d85a8c51ca2152e63f700d42bc5a5 (diff)
downloadgnu-guix-b651a5ab35414da54887780d03ea786ad4c894f2.tar
gnu-guix-b651a5ab35414da54887780d03ea786ad4c894f2.tar.gz
gnu: python-pandas: Update to 0.23.4.
* gnu/packages/python.scm (python-pandas): Update to 0.23.4. [arguments]: Disable "--strict-data-files" pytest option. Delete one more test. Adjust pytest invocation to be more verbose and skip very slow tests.
-rw-r--r--gnu/packages/python.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 56dd71cb5f..673c3cdfe4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1153,13 +1153,13 @@ human-friendly syntax.")
(define-public python-pandas
(package
(name "python-pandas")
- (version "0.23.1")
+ (version "0.23.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pandas" version))
(sha256
- (base32 "142nvwb01r2wv42y2cz40bx33hd8ffh6s6gynapg859fmzr2mdah"))))
+ (base32 "1x54pd7hr3y7qahx6b5bf2wzj54xvl8r3s1h4pl254pnmi3wl92v"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build utils)
@@ -1174,18 +1174,23 @@ human-friendly syntax.")
(getcwd) "/build/"
(car (scandir "build"
(cut string-prefix? "lib." <>))))))
+ ;; Disable the "strict data files" option which causes
+ ;; the build to error out if required data files are not
+ ;; available (as is the case with PyPI archives).
+ (substitute* "setup.cfg"
+ (("addopts = --strict-data-files") "addopts = "))
(with-directory-excursion build-directory
;; Delete tests that require "moto" which is not yet in Guix.
(for-each delete-file
'("pandas/tests/io/conftest.py"
"pandas/tests/io/json/test_compression.py"
+ "pandas/tests/io/parser/test_network.py"
"pandas/tests/io/test_excel.py"
"pandas/tests/io/test_parquet.py"))
- (invoke "pytest" "-v" "pandas" "-k"
- (string-append
- "not network and not disabled"
- ;; XXX: Due to the deleted tests above.
- " and not test_read_s3_jsonl")))))))))
+ (invoke "pytest" "-vv" "pandas" "--skip-slow"
+ "--skip-network" "-k"
+ ;; XXX: Due to the deleted tests above.
+ "not test_read_s3_jsonl"))))))))
(propagated-inputs
`(("python-numpy" ,python-numpy)
("python-pytz" ,python-pytz)