summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-29 15:41:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-29 15:41:06 +0200
commitb347317ae67c80d9ff3baca42aaab45002fc73e6 (patch)
tree0c6e064d340762f0848d0bb70b8b9c8fc16a5247
parent82b695b834f88c5561de40e68f3fe7aa24d3b796 (diff)
parent6cedd611774f91056c70d8d3a175d514b9b9fc76 (diff)
downloadgnu-guix-b347317ae67c80d9ff3baca42aaab45002fc73e6.tar
gnu-guix-b347317ae67c80d9ff3baca42aaab45002fc73e6.tar.gz
Merge branch 'master' into core-updates
-rw-r--r--NEWS5
-rw-r--r--gnu/bootloader/u-boot.scm16
-rw-r--r--gnu/packages/bootloaders.scm33
-rw-r--r--gnu/packages/calendar.scm4
-rw-r--r--gnu/packages/emacs.scm31
-rw-r--r--gnu/packages/engineering.scm7
-rw-r--r--gnu/packages/firmware.scm63
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch14
-rw-r--r--gnu/services/base.scm2
-rw-r--r--gnu/system/install.scm6
-rw-r--r--guix/download.scm5
11 files changed, 156 insertions, 30 deletions
diff --git a/NEWS b/NEWS
index 6003b5d577..0ce9611e1b 100644
--- a/NEWS
+++ b/NEWS
@@ -12,6 +12,11 @@ Please send Guix bug reports to bug-guix@gnu.org.
* Changes in 0.15.0 (since 0.14.0)
+** Package management
+
+*** ‘guix pack’ now supports building SquashFS images
+*** ‘guix pack’ can now build relocatable tarballs
+
** Distribution
*** New services
diff --git a/gnu/bootloader/u-boot.scm b/gnu/bootloader/u-boot.scm
index ea0f67b3cd..52b38dd1ab 100644
--- a/gnu/bootloader/u-boot.scm
+++ b/gnu/bootloader/u-boot.scm
@@ -37,6 +37,7 @@
u-boot-nintendo-nes-classic-edition-bootloader
u-boot-novena-bootloader
u-boot-pine64-plus-bootloader
+ u-boot-puma-rk3399-bootloader
u-boot-wandboard-bootloader))
(define install-u-boot
@@ -84,6 +85,15 @@
(write-file-on-device u-boot (stat:size (stat u-boot))
device (* 69 1024)))))
+(define install-puma-rk3399-u-boot
+ #~(lambda (bootloader device mount-point)
+ (let ((spl (string-append bootloader "/libexec/u-boot-spl.rksd"))
+ (u-boot (string-append bootloader "/libexec/u-boot.itb")))
+ (write-file-on-device spl (stat:size (stat spl))
+ device (* 64 512))
+ (write-file-on-device u-boot (stat:size (stat u-boot))
+ device (* 512 512)))))
+
;;;
@@ -162,3 +172,9 @@
(bootloader
(inherit u-boot-allwinner64-bootloader)
(package u-boot-pine64-plus)))
+
+(define u-boot-puma-rk3399-bootloader
+ (bootloader
+ (inherit u-boot-bootloader)
+ (package u-boot-puma-rk3399)
+ (installer install-puma-rk3399-u-boot)))
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 2dd530125f..a86c73731e 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -489,7 +489,7 @@ board-independent tools.")))
(let* ((out (assoc-ref outputs "out"))
(libexec (string-append out "/libexec"))
(uboot-files (append
- (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb)$")
+ (find-files "." ".*\\.(bin|efi|img|spl|itb|dtb|rksd)$")
(find-files "." "^(MLO|SPL)$"))))
(mkdir-p libexec)
(install-file ".config" libexec)
@@ -560,6 +560,37 @@ board-independent tools.")))
(define-public u-boot-cubieboard
(make-u-boot-package "Cubieboard" "arm-linux-gnueabihf"))
+(define-public u-boot-puma-rk3399
+ (let ((base (make-u-boot-package "puma-rk3399" "aarch64-linux-gnu")))
+ (package
+ (inherit base)
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'set-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Need to copy the firmware into u-boot build
+ ;; directory.
+ (copy-file (string-append (assoc-ref inputs "firmware")
+ "/bl31.bin") "bl31-rk3399.bin")
+ (copy-file (string-append (assoc-ref inputs "firmware-m0")
+ "/rk3399m0.bin") "rk3399m0.bin")
+ #t))
+ (add-after 'build 'build-itb
+ (lambda* (#:key make-flags #:allow-other-keys)
+ ;; The u-boot.itb is not built by default.
+ (apply invoke "make" `(,@make-flags ,"u-boot.itb"))))
+ (add-after 'build-itb 'build-rksd
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Build Rockchip SD card images.
+ (invoke "./tools/mkimage" "-T" "rksd" "-n" "rk3399" "-d"
+ "spl/u-boot-spl.bin" "u-boot-spl.rksd")))))))
+ (native-inputs
+ `(("firmware" ,arm-trusted-firmware-puma-rk3399)
+ ("firmware-m0" ,rk3399-cortex-m0)
+ ,@(package-native-inputs base))))))
+
(define-public vboot-utils
(package
(name "vboot-utils")
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index b2f6aec83d..d1aa9c256b 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -95,13 +95,13 @@ data units.")
(define-public khal
(package
(name "khal")
- (version "0.9.8")
+ (version "0.9.9")
(source (origin
(method url-fetch)
(uri (pypi-uri "khal" version))
(sha256
(base32
- "1blx3gxnv7sj302biqphfw7i6ilzl2xlmvzp130n3113scg9w17y"))))
+ "0dq9aqb9pqjfqrnfg43mhpb7m0szmychxy1ydb3lwzf3500c9rsh"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8c28b252dc..79816e9aaa 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -114,14 +114,14 @@
(define-public emacs
(package
(name "emacs")
- (version "25.3")
+ (version "26.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/emacs/emacs-"
version ".tar.xz"))
(sha256
(base32
- "02y00y9q42g1iqgz5qhmsja75hwxd88yrn9zp14lanay0zkwafi5"))
+ "0b6k1wq44rc8gkvxhi1bbjxbz3cwg29qbq8mklq2az6p1hjgrx0w"))
(patches (search-patches "emacs-exec-path.patch"
"emacs-fix-scheme-indent-function.patch"
"emacs-source-date-epoch.patch"))
@@ -160,7 +160,8 @@
#t))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:phases
+ `(#:tests? #f ; no check target
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'fix-/bin/pwd
(lambda _
@@ -246,10 +247,11 @@ languages.")
(synopsis "The extensible text editor (used only for byte-compilation)")
(build-system gnu-build-system)
(arguments
- (substitute-keyword-arguments (package-arguments emacs)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'install-site-start)))))
+ `(#:configure-flags (list "--with-gnutls=no")
+ ,@(substitute-keyword-arguments (package-arguments emacs)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'install-site-start))))))
(inputs
`(("ncurses" ,ncurses)))
(native-inputs
@@ -1584,16 +1586,16 @@ and stored in memory.")
(define-public emacs-dash
(package
(name "emacs-dash")
- (version "2.13.0")
+ (version "2.14.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/magnars/dash.el/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magnars/dash.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1pjlkrzr8n45bnp3xs3dybvy0nz3gwamrfc7vsi1nhpkkw99ihhb"))))
+ "1kzijmjxjxgr7p8clphzvmm47vczckbs8mza9an77c25bn627ywl"))))
(build-system emacs-build-system)
(arguments
`(#:tests? #t
@@ -1796,6 +1798,7 @@ allows easily move between them.")
(build-system emacs-build-system)
(arguments
`(#:tests? #t
+ #:emacs ,emacs ; FIXME: tests fail with emacs-minimal
#:test-command '("./run-tests.sh")))
(home-page "https://github.com/magnars/s.el")
(synopsis "Emacs string manipulation library")
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 13d24997ed..0f137dd035 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -110,6 +110,13 @@
(string-append "#include <boost/serialization/array_wrapper.hpp>\n"
line)))
#t))
+ ;; Fix build against Qt 5.11.
+ (add-after 'unpack 'add-missing-headers
+ (lambda _
+ (substitute* "librecad/src/ui/generic/widgetcreator.cpp"
+ (("#include <QPushButton>") "#include <QPushButton>
+#include <QActionGroup>"))
+ #t))
(add-after 'unpack 'patch-paths
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 9e91ceca4e..986e1d6219 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -404,3 +404,66 @@ such as:
(sha256
(base32
"0r4xnlq7v9khjfcg6gqp7nmrmnw4z1r8bipwdr07png1dcbb8214")))))))
+
+(define-public arm-trusted-firmware-puma-rk3399
+ (let ((base (make-arm-trusted-firmware "rk3399"))
+ ;; Vendor's arm trusted firmware branch hasn't been upstreamed yet.
+ (commit "d71e6d83612df896774ec4c03d49500312d2c324")
+ (revision "1"))
+ (package
+ (inherit base)
+ (name "arm-trusted-firmware-puma-rk3399")
+ (version (git-version "1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.theobroma-systems.com/arm-trusted-firmware.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vqhwqqh8h9qlkpybg2v94911091c1418bc4pnzq5fd7zf0fjkf8")))))))
+
+(define-public rk3399-cortex-m0
+ (package
+ (name "rk3399-cortex-m0")
+ (version "1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.theobroma-systems.com/rk3399-cortex-m0.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "rk3399-cortex-m0" version))
+ (sha256
+ (base32
+ "02wz1vkf4j3zc8rx289z76xhrf71jhb2p05lvmygky393a9gjh9w"))))
+ (home-page "https://git.theobroma-systems.com/rk3399-cortex-m0.git/about/")
+ (synopsis "PMU Cortex M0 firmware for RK3399 Q7 (Puma)")
+ (description
+ "Cortex-M0 firmware used with the RK3399 to implement
+power-management functionality and helpers (e.g. DRAM frequency
+switching support).\n")
+ (license license:bsd-3)
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (mzerofiles (find-files "." "rk3399m0.(elf|bin)$")))
+ (for-each
+ (lambda (file)
+ (install-file file out))
+ mzerofiles))
+ #t))
+ (add-before 'build 'setenv
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CROSS_COMPILE" "arm-none-eabi-")
+ #t)))))
+ (native-inputs `(("cross-gcc" ,(cross-gcc "arm-none-eabi" #:xgcc gcc-7))
+ ("cross-binutils" ,(cross-binutils "arm-none-eabi"))))))
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
index c5a426802c..4b7904ea3b 100644
--- a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
--- a/lisp/progmodes/scheme.el
+++ b/lisp/progmodes/scheme.el
-@@ -482,6 +482,12 @@
- (> (length function) 3)
- (string-match "\\`def" function)))
- (lisp-indent-defform state indent-point))
+@@ -494,6 +494,12 @@ indentation."
+ (> (length function) 3)
+ (string-match "\\`def" function)))
+ (lisp-indent-defform state indent-point))
+ ((and (null method)
+ (> (length function) 1)
+ ;; The '#' in '#:' seems to get lost, not sure why
+ (string-match "\\`:" function))
+ (let ((lisp-body-indent 1))
+ (lisp-indent-defform state indent-point)))
- ((integerp method)
- (lisp-indent-specform method state
- indent-point normal-indent))
+ ((integerp method)
+ (lisp-indent-specform method state
+ indent-point normal-indent))
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 09a1ce95e3..b34bb7132b 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -306,7 +306,7 @@ seconds after @code{SIGTERM} has been sent are terminated with
(string-append (match (file-system-device file-system)
((? file-system-label? label)
(string-append "LABEL="
- (file-system-label->string file-system)))
+ (file-system-label->string label)))
((? uuid? uuid)
(string-append "UUID=" (uuid->string uuid)))
((? string? device)
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index acc9f15e0d..35f4ba9c24 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -53,6 +53,7 @@
nintendo-nes-classic-edition-installation-os
novena-installation-os
pine64-plus-installation-os
+ rk3399-puma-installation-os
wandboard-installation-os))
;;; Commentary:
@@ -451,6 +452,11 @@ The bootloader BOOTLOADER is installed to BOOTLOADER-TARGET."
"/dev/mmcblk0" ; SD card storage
"ttyS0"))
+(define rk3399-puma-installation-os
+ (embedded-installation-os u-boot-puma-rk3399-bootloader
+ "/dev/mmcblk0" ; SD card storage
+ "ttyS0"))
+
(define wandboard-installation-os
(embedded-installation-os u-boot-wandboard-bootloader
"/dev/mmcblk0" ; SD card storage
diff --git a/guix/download.scm b/guix/download.scm
index 66d97eed44..988117885c 100644
--- a/guix/download.scm
+++ b/guix/download.scm
@@ -391,11 +391,6 @@
(plain-file "content-addressed-mirrors"
(object->string %content-addressed-mirrors)))
-(define (gnutls-package)
- "Return the default GnuTLS package."
- (let ((module (resolve-interface '(gnu packages tls))))
- (module-ref module 'gnutls)))
-
(define built-in-builders*
(let ((cache (make-weak-key-hash-table)))
(lambda ()