summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:56:36 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commitb18f875f20daf0a92471194407c2f0f05c3aa41b (patch)
tree96c0ada597b3449fbd9a5b67e3a370bfd3313e04
parentd1042c6c5b2bcbb2525e3347e3ff83475b03ffb8 (diff)
downloadgnu-guix-b18f875f20daf0a92471194407c2f0f05c3aa41b.tar
gnu-guix-b18f875f20daf0a92471194407c2f0f05c3aa41b.tar.gz
gnu: Add python-proselint.
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index aae33564c1..381c686a39 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15458,3 +15458,27 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Dummy to remind people to switch to 'pip install mypy'")
(license #f)))
+
+(define-public python-proselint
+ (package
+ (name "python-proselint")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "proselint" version))
+ (sha256
+ (base32
+ "1g8vx04gmv0agmggz1ml5vydfppqvl8dzjvqm6vqw5rzafa89m08"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-future" ,python-future)
+ ("python-click" ,python-click)))
+ (home-page
+ "http://github.com/amperser/proselint")
+ (synopsis "A linter for prose")
+ (description "A linter for prose")
+ (license license:bsd-3)))