summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:55:30 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:53 +0000
commita8e7477aa46e75c5ada4b62502a831b040812bca (patch)
tree24dc41a57557285608121a10d72e0d710d150e8c
parent2bc91e4d7e26e8560943576bbe6b5cd522413fbf (diff)
downloadgnu-guix-a8e7477aa46e75c5ada4b62502a831b040812bca.tar
gnu-guix-a8e7477aa46e75c5ada4b62502a831b040812bca.tar.gz
gnu: Add python-cpplint.
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d67693c8c8..22f0e61920 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15311,3 +15311,23 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Find problems in C++ source that slow development of large code bases.")
(license #f)))
+
+(define-public python-cpplint
+ (package
+ (name "python-cpplint")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cpplint" version))
+ (sha256
+ (base32
+ "06b7jf9vii2rp8q05h5h6jsrflrwpv2bd5chrj2drij476f16xk8"))))
+ (build-system python-build-system)
+ (home-page
+ "http://en.wikipedia.org/wiki/Cpplint")
+ (synopsis
+ "An automated checker to make sure a C++ file follows Google's C++ style guide")
+ (description
+ "An automated checker to make sure a C++ file follows Google's C++ style guide")
+ (license #f)))