summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-04-14 19:09:08 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commita70113a0b3d0a1bba8d3da04df6fa6399bd01426 (patch)
tree3e802b279124b9bca6d3d07e5c9f5af723aa6dad
parent1ab9ea0e7312ef00985d696c82adf307ba6f366b (diff)
downloadgnu-guix-a70113a0b3d0a1bba8d3da04df6fa6399bd01426.tar
gnu-guix-a70113a0b3d0a1bba8d3da04df6fa6399bd01426.tar.gz
gnu: Add ruby-kgio.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 46595dbe24..20a697bcab 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8978,3 +8978,30 @@ but it can function as a stand-alone templating engine.")
"Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc.")
(home-page "http://github.com/alexch/rerun/")
(license license:expat)))
+
+(define-public ruby-kgio
+ (package
+ (name "ruby-kgio")
+ (version "2.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "kgio" version))
+ (sha256
+ (base32
+ "1528pyj1szzzp3pgj05fzjd36qjrxm9yj2x5radc9p1z7vl67y50"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "This is a legacy project, do not use it for new projects. Ruby
+2.3 and later should make this obsolete. kgio provides
+non-blocking I/O methods for Ruby without raising exceptions on
+EAGAIN and EINPROGRESS.")
+ (description
+ "This is a legacy project, do not use it for new projects. Ruby
+2.3 and later should make this obsolete. kgio provides
+non-blocking I/O methods for Ruby without raising exceptions on
+EAGAIN and EINPROGRESS.")
+ (home-page "https://bogomips.org/kgio/")
+ (license #f)))