summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-24 18:06:08 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-24 23:40:49 +0200
commit9d3c4daed35b3393ea06e168ab669813a3278b60 (patch)
tree0972001231998c97f484cf2fc4cca0bdd9664d60
parent2365338b18b54a911c77d50925b63b42479960e8 (diff)
downloadgnu-guix-9d3c4daed35b3393ea06e168ab669813a3278b60.tar
gnu-guix-9d3c4daed35b3393ea06e168ab669813a3278b60.tar.gz
gnu: racket: Add dependency on GTK+.
* gnu/packages/scheme.scm (racket): Add dependency on GTK+ and gdk-pixbuf.
-rw-r--r--gnu/packages/scheme.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 43853fa08c..b7df902136 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages avahi)
#:use-module (gnu packages libphidget)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libjpeg)
#:use-module ((gnu packages gtk) #:select (cairo pango))
@@ -358,12 +359,15 @@ implementation techniques and as an expository tool.")
'(#:phases
(let* ((gui-libs
(lambda (inputs)
- ;; FIXME: Add GTK+ and GDK for DrRacket.
- (let ((glib (string-append (assoc-ref inputs "glib") "/lib"))
- (cairo (string-append (assoc-ref inputs "cairo") "/lib"))
- (pango (string-append (assoc-ref inputs "pango") "/lib"))
- (libjpeg (string-append (assoc-ref inputs "libjpeg") "/lib")))
- (list glib cairo pango libjpeg)))))
+ (define (lib input)
+ (string-append (assoc-ref inputs input) "/lib"))
+
+ (list (lib "glib")
+ (lib "cairo")
+ (lib "pango")
+ (lib "libjpeg")
+ (lib "gtk")
+ (lib "gdk-pixbuf")))))
(alist-cons-before
'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
@@ -397,7 +401,9 @@ implementation techniques and as an expository tool.")
("glib" ,glib) ; for DrRacket
("cairo" ,cairo)
("pango" ,pango)
- ("libjpeg" ,libjpeg-8)))
+ ("libjpeg" ,libjpeg-8)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gtk" ,gtk+)))
(home-page "http://racket-lang.org")
(synopsis "Implementation of Scheme and related languages")
(description