summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:11 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:46:23 +0000
commit952747496bf848bcc7fc05874c0efeebdb777188 (patch)
tree6c7a2d9211e57acd7864b0765f3eb92c8df3aa5f
parentcc19d660a0f8d3fa6ba3825bb2c3a43cd7f0e41f (diff)
downloadgnu-guix-952747496bf848bcc7fc05874c0efeebdb777188.tar
gnu-guix-952747496bf848bcc7fc05874c0efeebdb777188.tar.gz
gnu: Add ruby-thread-order.
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 40827e0246..f339605292 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2838,6 +2838,40 @@ file or directories are modified.")
(home-page "http://guardgem.org/")
(license license:expat)))
+(define-public ruby-thread-order
+ (package
+ (name "ruby-thread-order")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "thread_order" version))
+ (sha256
+ (base32
+ "1n8zs3m7na5jmpf0pw0z79vg0x0lfzajpynp28zb43l89l00qcfi"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)))
+ (arguments
+ '(;; TODO: 1 test fails
+ ;; 1) ThreadOrder is implemented without depending on the stdlib
+ ;; Failure/Error: expect(loaded_filenames).to_not include 'monitor.rb'
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "rspec")
+ #t))))))
+ (synopsis
+ "Test helper for ordering threaded code (does not depend on gems or stdlib, tested on 1.8.7 - 2.2, rbx, jruby).")
+ (description
+ "Test helper for ordering threaded code (does not depend on gems or stdlib, tested on 1.8.7 - 2.2, rbx, jruby).")
+ (home-page
+ "https://github.com/JoshCheek/thread_order")
+ (license license:expat)))
+
(define-public ruby-thread-safe
(package
(name "ruby-thread-safe")