summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 11:16:47 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commit9472be835762701390bbe7d7da27f3f3b90c5747 (patch)
tree3a0535f449e933b70fe3728ac65225c07b9055a4
parent58e8c06280f46937ce48c882b5b6a18cbf0b49ee (diff)
downloadgnu-guix-9472be835762701390bbe7d7da27f3f3b90c5747.tar
gnu-guix-9472be835762701390bbe7d7da27f3f3b90c5747.tar.gz
gnu: Add ruby-sucker-punch.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6b1994a490..17ed253218 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8695,3 +8695,27 @@ but it can function as a stand-alone templating engine.")
(home-page
"https://github.com/tobyclemson/ruby_terraform")
(license license:expat)))
+
+(define-public ruby-sucker-punch
+ (package
+ (name "ruby-sucker-punch")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "sucker_punch" version))
+ (sha256
+ (base32
+ "064dgfg3jwna2x1iyhbz3pvh3iryxs4vls77jmmad571hjz0l01p"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-concurrent" ,ruby-concurrent)))
+ (synopsis
+ "Asynchronous processing library for Ruby")
+ (description
+ "Asynchronous processing library for Ruby")
+ (home-page
+ "https://github.com/brandonhilkert/sucker_punch")
+ (license license:expat)))