summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-18 11:21:17 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commit9301271871df2ee9ddae44a8307498e744c94931 (patch)
tree544e7edd143f023257ef96a1aad3b01a0d2bf1d8
parent21208d300af11f93371faf67a732101c4e78ad7e (diff)
downloadgnu-guix-9301271871df2ee9ddae44a8307498e744c94931.tar
gnu-guix-9301271871df2ee9ddae44a8307498e744c94931.tar.gz
gnu: Add ruby-rerun.
* gnu/packages/ruby.scm (ruby-rerun): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 08d8fb4375..eef5f3b79e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8955,3 +8955,26 @@ but it can function as a stand-alone templating engine.")
(home-page
"https://github.com/opperator/warden-oauth2")
(license #f)))
+
+(define-public ruby-rerun
+ (package
+ (name "ruby-rerun")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rerun" version))
+ (sha256
+ (base32
+ "1cskvxk8z8vmfail8na7hj91hs0qnvds9nydj04zi3dbddgnbmvz"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-listen" ,ruby-listen)))
+ (synopsis
+ "Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc.")
+ (description
+ "Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc.")
+ (home-page "http://github.com/alexch/rerun/")
+ (license license:expat)))