summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-01 12:06:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-01 12:06:17 +0100
commit8a4644336d5063fd0bf43e90e3c0823c76e82e4e (patch)
treeec0667860fe290621b55ce81f6eb17acd3bf1c31
parente896c227e3ce536ae264361c40aa88d83d092776 (diff)
downloadgnu-guix-8a4644336d5063fd0bf43e90e3c0823c76e82e4e.tar
gnu-guix-8a4644336d5063fd0bf43e90e3c0823c76e82e4e.tar.gz
gnu: libvpx: Update to 1.7.0.
* gnu/packages/video.scm (libvpx): Update to 1.7.0. [source]: Use GIT-FETCH.
-rw-r--r--gnu/packages/video.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0f419e3571..8cbe590bf2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1115,15 +1115,17 @@ access to mpv's powerful playback capabilities.")
(define-public libvpx
(package
(name "libvpx")
- (version "1.6.1")
+ (version "1.7.0")
(source (origin
- (method url-fetch)
- (uri (string-append "http://storage.googleapis.com/"
- "downloads.webmproject.org/releases/webm/"
- name "-" version ".tar.bz2"))
+ ;; XXX: Upstream does not provide tarballs for > 1.6.1.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://chromium.googlesource.com/webm/libvpx")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "06d8hqjkfs6wl45qf4pwh1kpbvkx6cwywd5y8d4lgagvjwm0qb0w"))
+ "0vvh89hvp8qg9an9vcmwb7d9k3nixhxaz6zi65qdjnd0i56kkcz6"))
(patches (search-patches "libvpx-CVE-2016-2818.patch"))))
(build-system gnu-build-system)
(arguments