summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:58:40 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commit8758a1be3421250ead2f4744a67bc2695d3a8970 (patch)
tree1c7b308a51093c49460fed6cf74e671d6ff03823
parent7ff64c84113b4600a939e7abbd2a02ef07789de0 (diff)
downloadgnu-guix-8758a1be3421250ead2f4744a67bc2695d3a8970.tar
gnu-guix-8758a1be3421250ead2f4744a67bc2695d3a8970.tar.gz
gnu: Add python-pathspec.
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index db4db2a585..8cfe902ad1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15704,3 +15704,23 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(synopsis "Find dead code")
(description "Find dead code")
(license license:expat)))
+
+(define-public python-pathspec
+ (package
+ (name "python-pathspec")
+ (version "0.5.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pathspec" version))
+ (sha256
+ (base32
+ "1lyhyc6ps4imcj4f99c3njqf3wk2c0f6szrhkqhp8rp7pg8rbi3j"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/cpburnz/python-path-specification")
+ (synopsis
+ "Utility library for gitignore style pattern matching of file paths.")
+ (description
+ "Utility library for gitignore style pattern matching of file paths.")
+ (license #f)))