summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-05-30 19:44:15 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-06-23 00:14:27 +0200
commit7f93bbd5aadf0427190769fba8f478c29e37b4f4 (patch)
treecd5e247f623c358d7e20690700c98a3673717f13
parentbdd235b30bd8502b6b2241dde0f956d0b50e4572 (diff)
downloadgnu-guix-7f93bbd5aadf0427190769fba8f478c29e37b4f4.tar
gnu-guix-7f93bbd5aadf0427190769fba8f478c29e37b4f4.tar.gz
services: Add fingerprint identification service.
* gnu/services/authentication.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * doc/guix.texi (Miscellaneous Services): Document it.
-rw-r--r--doc/guix.texi15
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/services/authentication.scm41
3 files changed, 57 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 1ecb110020..74c10e4bbf 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -20043,6 +20043,21 @@ The port to bind the server to.
@node Miscellaneous Services
@subsubsection Miscellaneous Services
+@cindex fingerprint
+@subsubheading Fingerprint Service
+
+The @code{(gnu services fingerprint)} module provides a DBus service to
+read and identify fingerprints via a fingerprint sensor.
+
+@defvr {Scheme Variable} fprintd-service-type
+The service type for @command{fprintd}, which provides the fingerprint
+reading capability.
+
+@example
+(service fprintd-service-type)
+@end example
+@end defvr
+
@cindex sysctl
@subsubheading System Control Service
diff --git a/gnu/local.mk b/gnu/local.mk
index 8a9559328b..9d8947d55d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -471,6 +471,7 @@ GNU_SYSTEM_MODULES = \
%D%/services/desktop.scm \
%D%/services/dict.scm \
%D%/services/dns.scm \
+ %D%/services/authentication.scm \
%D%/services/games.scm \
%D%/services/kerberos.scm \
%D%/services/lirc.scm \
diff --git a/gnu/services/authentication.scm b/gnu/services/authentication.scm
new file mode 100644
index 0000000000..1ab2b03003
--- /dev/null
+++ b/gnu/services/authentication.scm
@@ -0,0 +1,41 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services fingerprint)
+ #:use-module (gnu services)
+ #:use-module (gnu services dbus)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (guix gexp)
+ #:use-module (guix records)
+ #:export (fprintd-configuration
+ fprintd-configuration?
+ fprintd-service-type))
+
+(define-record-type* <fprintd-configuration>
+ fprintd-configuration make-fprintd-configuration
+ fprintd-configuration?
+ (ntp fprintd-configuration-fprintd
+ (default fprintd)))
+
+(define fprintd-service-type
+ (service-type (name 'fprintd)
+ (extensions
+ (list (service-extension dbus-root-service-type
+ list)))
+ (description
+ "Run fprintd, a fingerprint management daemon.")))