summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-19 17:47:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-19 18:03:04 +0200
commit7c16af4646fac789000495064a13284691dbeb75 (patch)
tree8bcd3361fa646fc6566fa68c3f03596818b48fea
parent44b98b00026e62766620dbc4330a305282d61069 (diff)
downloadgnu-guix-7c16af4646fac789000495064a13284691dbeb75.tar
gnu-guix-7c16af4646fac789000495064a13284691dbeb75.tar.gz
gnu: python-bcrypt: Move to (gnu packages python-crypto).
* gnu/packages/password-utils.scm (python-bcrypt, python2-bcrypt): Move to ... * gnu/packages/python-crypto.scm (python-bcrypt, python2-bcrypt): ... here. * gnu/packages/python.scm: Remove unused (gnu packages password-utils) import.
-rw-r--r--gnu/packages/password-utils.scm31
-rw-r--r--gnu/packages/python-crypto.scm31
-rw-r--r--gnu/packages/python.scm1
3 files changed, 31 insertions, 32 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index f4518cfeb0..923122903e 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -457,37 +457,6 @@ winner of the 2015 Password Hashing Competition.")
;; files are CC0 only; see README.md and LICENSE for details.
(license (list license:cc0 license:asl2.0))))
-(define-public python-bcrypt
- (package
- (name "python-bcrypt")
- (version "3.1.4")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "bcrypt" version))
- (sha256
- (base32
- "13cyrnqwkhc70rs6dg65z4yrrr3dc42fhk11804fqmci9hvimvb7"))))
- (build-system python-build-system)
- (native-inputs
- `(("python-pycparser" ,python-pycparser)
- ("python-pytest" ,python-pytest)))
- (propagated-inputs
- `(("python-cffi" ,python-cffi)
- ("python-six" ,python-six)))
- (home-page "https://github.com/pyca/bcrypt/")
- (synopsis
- "Modern password hashing library")
- (description
- "Bcrypt is a Python module which provides a password hashing method based
-on the Blowfish password hashing algorithm, as described in
-@url{http://static.usenix.org/events/usenix99/provos.html,\"A Future-Adaptable
-Password Scheme\"} by Niels Provos and David Mazieres.")
- (license license:asl2.0)))
-
-(define-public python2-bcrypt
- (package-with-python2 python-bcrypt))
-
(define-public pass-git-helper
(package
(name "pass-git-helper")
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index ace0891a7d..bf868b14d7 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -48,6 +48,37 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-bcrypt
+ (package
+ (name "python-bcrypt")
+ (version "3.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bcrypt" version))
+ (sha256
+ (base32
+ "13cyrnqwkhc70rs6dg65z4yrrr3dc42fhk11804fqmci9hvimvb7"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pycparser" ,python-pycparser)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-cffi" ,python-cffi)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/pyca/bcrypt/")
+ (synopsis
+ "Modern password hashing library")
+ (description
+ "Bcrypt is a Python module which provides a password hashing method based
+on the Blowfish password hashing algorithm, as described in
+@url{http://static.usenix.org/events/usenix99/provos.html,\"A Future-Adaptable
+Password Scheme\"} by Niels Provos and David Mazieres.")
+ (license license:asl2.0)))
+
+(define-public python2-bcrypt
+ (package-with-python2 python-bcrypt))
+
(define-public python-passlib
(package
(name "python-passlib")
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fe66d8d082..ae6e38f024 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -102,7 +102,6 @@
#:use-module (gnu packages networking)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages openstack)
- #:use-module (gnu packages password-utils)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)