summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-02 14:45:15 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-02 14:54:24 +0100
commit7355634db3ccf0d86f8e34c4aea37392c1a0ab0a (patch)
tree424f82554e955eec521b70eab1543ca822490f10
parent9af076245f2e9e708314e4267c2f7c732aaff3b2 (diff)
downloadgnu-guix-7355634db3ccf0d86f8e34c4aea37392c1a0ab0a.tar
gnu-guix-7355634db3ccf0d86f8e34c4aea37392c1a0ab0a.tar.gz
gnu: Disambiguate packages with the same name.
* gnu/packages/algebra.scm (fftw-with-threads, fftwf-with-threads): Add 'name' field. * gnu/packages/llvm.scm (llvm-for-extempore): Likewise.
-rw-r--r--gnu/packages/algebra.scm4
-rw-r--r--gnu/packages/llvm.scm3
2 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 8e3327eafe..892b6cf525 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
@@ -581,6 +581,7 @@ cosine/ sine transforms or DCT/DST).")
;; "--enable-flags" is added to the fftw and fftwf packages.
(define-public fftw-with-threads
(package (inherit fftw)
+ (name "fftw-pthreads")
(arguments
(substitute-keyword-arguments (package-arguments fftw)
((#:configure-flags flags)
@@ -588,6 +589,7 @@ cosine/ sine transforms or DCT/DST).")
(define-public fftwf-with-threads
(package (inherit fftwf)
+ (name "fftwf-pthreads")
(arguments
(substitute-keyword-arguments (package-arguments fftwf)
((#:configure-flags flags)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index c425108c93..04a2b39af9 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Dennis Mungai <dmngaie@gmail.com>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
@@ -283,6 +283,7 @@ code analysis tools.")
(define-public llvm-for-extempore
(package (inherit llvm-3.7)
+ (name "llvm-for-extempore")
(source
(origin
(inherit (package-source llvm-3.7))