summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:41:47 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:46:23 +0000
commit6e41bfd8ff4b5f2dca948ddac513c42a2f4439db (patch)
tree8a0e8ae26ffdb1ea9a4047fc089df5a60efdf65b
parentf7c4b57ca472faa1776b8a55e0f8019faed22ca2 (diff)
downloadgnu-guix-6e41bfd8ff4b5f2dca948ddac513c42a2f4439db.tar
gnu-guix-6e41bfd8ff4b5f2dca948ddac513c42a2f4439db.tar.gz
gnu: Add ruby-fuubar.
-rw-r--r--gnu/packages/ruby.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e860a0748f..a85c6353aa 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1212,6 +1212,46 @@ standard output stream.")
(home-page "https://github.com/geemus/formatador")
(license license:expat)))
+(define-public ruby-fuubar
+ (package
+ (name "ruby-fuubar")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; The gem does not include files required for testing.
+ (uri (string-append "https://github.com/thekompanee/fuubar/archive/releases/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1363fy7x12srr51cy5x1xkf9z7jlzzlwpsifwgx6bivnp6lar3ny"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f ; some tests fail when running (zero? (system* "rspec"
+ ; "-Ilib" "spec")) inside the container, but seem to work outside.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'delete-certificate
+ (lambda _
+ ;; Remove 's.cert_chain' as we do not build with a private key
+ (substitute* "fuubar.gemspec"
+ ((".*cert_chain.*") "")
+ ((".*signing_key.*") ""))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (propagated-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("ruby-ruby-progressbar" ,ruby-ruby-progressbar)))
+ (synopsis
+ "the instafailing RSpec progress bar formatter")
+ (description
+ "the instafailing RSpec progress bar formatter")
+ (home-page
+ "https://github.com/thekompanee/fuubar")
+ (license license:expat)))
+
(define-public ruby-shindo
(package
(name "ruby-shindo")