summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-18 22:19:16 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commit6e0d866bc6e473591edd5e32246baacdb0030285 (patch)
tree60140a9f24601b21d801298cc8e320e4b2ba209e
parent1925c28e65db4655c2b7b337da7bebf7bc801e82 (diff)
downloadgnu-guix-6e0d866bc6e473591edd5e32246baacdb0030285.tar
gnu-guix-6e0d866bc6e473591edd5e32246baacdb0030285.tar.gz
gnu: Add ruby-annotate.
-rw-r--r--gnu/packages/rails.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index dd9ba4830f..0db866cf75 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -640,3 +640,37 @@ API.")
(description "Squash your old migrations")
(home-page "https://github.com/jalkoby/squasher")
(license license:expat)))
+
+(define-public ruby-annotate
+ (package
+ (name "ruby-annotate")
+ (version "2.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "annotate" version))
+ (sha256
+ (base32
+ "079y33iy65nv1cqnh1zmi3v2y9yp1z3zzsf2wdh35m3c80v6kaz4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-annotate
+ (lambda _
+ (substitute* "bin/annotate"
+ (("require 'bundler'")
+ "")
+ (("Bundler.setup")
+ "")))))))
+ (propagated-inputs
+ `(("ruby-activerecord" ,ruby-activerecord)
+ ("ruby-activesupport" ,ruby-activesupport)))
+ (synopsis
+ "Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.")
+ (description
+ "Annotates Rails/ActiveRecord Models, routes, fixtures, and others based on the database schema.")
+ (home-page
+ "http://github.com/ctran/annotate_models")
+ (license #f)))