summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2014-12-16 18:34:37 +0100
committerFederico Beffa <beffa@fbengineering.ch>2014-12-16 18:37:13 +0100
commit6a843168489faa0873a33990037aaa8844bf0d23 (patch)
tree51b873cc4616b29a828cf87107da253f20ae50d2
parent81de56479a30651dac542ed392296205c4ea5508 (diff)
downloadgnu-guix-6a843168489faa0873a33990037aaa8844bf0d23.tar
gnu-guix-6a843168489faa0873a33990037aaa8844bf0d23.tar.gz
Revert "gnu: python-numpy-bootstrap: Reduce matrix size in failing test."
This reverts commit 31557440c29f8d93b366422bfec4dab341eff79f as it did not provide the desired effect. The test is still failing.
-rw-r--r--gnu/packages/python.scm29
1 files changed, 11 insertions, 18 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 183fd54ac8..dc7def5507 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1928,24 +1928,17 @@ writing C extensions for Python as easy as Python itself.")
(string-append (assoc-ref inputs "atlas")
"/lib/libsatlas.so"))))
(setenv "ATLAS" atlas-lib)))
- (alist-cons-before
- 'check 'fix-failing-tests
- (lambda _
- (substitute* (find-files "numpy/linalg/tests"
- "test_regression\\.py")
- (("x = np.eye(1000, 66)")
- "x = np.eye(10, 66)")))
- ;; Tests can only be run after the library has been installed and not
- ;; within the source directory.
- (alist-cons-after
- 'install 'check
- (lambda _
- (with-directory-excursion "/tmp"
- (zero? (system* "python" "-c"
- "import numpy; numpy.test(verbose=2)"))))
- (alist-delete
- 'check
- %standard-phases))))))
+ ;; Tests can only be run after the library has been installed and not
+ ;; within the source directory.
+ (alist-cons-after
+ 'install 'check
+ (lambda _
+ (with-directory-excursion "/tmp"
+ (zero? (system* "python" "-c"
+ "import numpy; numpy.test(verbose=2)"))))
+ (alist-delete
+ 'check
+ %standard-phases)))))
(home-page "http://www.numpy.org/")
(synopsis "Fundamental package for scientific computing with Python")
(description "NumPy is the fundamental package for scientific computing