summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-04-14 19:09:36 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commit6a61fdc8fa598538b4c15e16ddb74bf65c50ab21 (patch)
tree182653143fe603396fca36d866214afa7afb937a
parent532a0990f0e548df694c53e62e35301171b0762e (diff)
downloadgnu-guix-6a61fdc8fa598538b4c15e16ddb74bf65c50ab21.tar
gnu-guix-6a61fdc8fa598538b4c15e16ddb74bf65c50ab21.tar.gz
gnu: Add ruby-unicorn.
-rw-r--r--gnu/packages/web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 84bd795a85..c1d29c94ad 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -57,6 +57,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system ruby)
#:use-module (guix build-system cmake)
#:use-module (guix build-system r)
#:use-module (guix build-system trivial)
@@ -113,6 +114,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages xml)
#:use-module (gnu packages curl)
@@ -6878,3 +6880,33 @@ instructions on how to use Guix in a shared HPC environment.")
"This package provides UI widget and layout functions for writing Shiny apps that
work well on small screens.")
(license l:gpl3)))
+
+(define-public ruby-unicorn
+ (package
+ (name "ruby-unicorn")
+ (version "5.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "unicorn" version))
+ (sha256
+ (base32
+ "09s3mdsrc080h7b70lkl2wnv36iy9ipdqbi1ffm3fxd0498xjb7h"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-kgio" ,ruby-kgio)
+ ("ruby-raindrops" ,ruby-raindrops)))
+ (synopsis
+ "unicorn is an HTTP server for Rack applications designed to only serve
+fast clients on low-latency, high-bandwidth connections and take
+advantage of features in Unix/Unix-like kernels. Slow clients should
+only be served by placing a reverse proxy capable of fully buffering
+both the the request and response in between unicorn and slow clients.")
+ (description
+ "unicorn is an HTTP server for Rack applications designed to only serve
+fast clients on low-latency, high-bandwidth connections and take
+advantage of features in Unix/Unix-like kernels. Slow clients should
+only be served by placing a reverse proxy capable of fully buffering
+both the the request and response in between unicorn and slow clients.")
+ (home-page "https://bogomips.org/unicorn/")
+ (license (list #f #f))))