summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-08-01 07:39:42 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:46:23 +0000
commit691d2f1ba1cbab278afe981ae3fe55292e28c929 (patch)
tree8a6c74bb9ab9019f9c2725aa0f226aed9527199f
parent24c258c1bd3035c6be25eeeff052505c167a6622 (diff)
downloadgnu-guix-691d2f1ba1cbab278afe981ae3fe55292e28c929.tar
gnu-guix-691d2f1ba1cbab278afe981ae3fe55292e28c929.tar.gz
gnu: Add ruby-psych.
* gnu/packages/ruby.scm (ruby-psych): New variable.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d4e6432ed4..b034e9264e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2697,6 +2697,34 @@ invocation, and source and documentation browsing.")
(home-page "https://pryrepl.org")
(license license:expat)))
+(define-public ruby-psych
+ (package
+ (name "ruby-psych")
+ (version "3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "psych" version))
+ (sha256
+ (base32
+ "0g9yrzzfza5yjfnn4pkykr71fhpayahvimvyyv8xi3i34a03v9xg"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis
+ "Psych is a YAML parser and emitter. Psych leverages libyaml[http://pyyaml.org/wiki/LibYAML]
+for its YAML parsing and emitting capabilities. In addition to wrapping libyaml,
+Psych also knows how to serialize and de-serialize most Ruby objects to and from the YAML format.
+")
+ (description
+ "Psych is a YAML parser and emitter. Psych leverages libyaml[http://pyyaml.org/wiki/LibYAML]
+for its YAML parsing and emitting capabilities. In addition to wrapping libyaml,
+Psych also knows how to serialize and de-serialize most Ruby objects to and from the YAML format.
+")
+ (home-page "https://github.com/ruby/psych")
+ (license license:expat)))
+
(define-public ruby-guard
(package
(name "ruby-guard")