summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-05-09 18:52:31 +0000
committerLudovic Courtès <ludo@gnu.org>2017-12-01 11:28:48 +0100
commit6101cad4d19cf1c32d6abf7c9ef2a86ad9d986c5 (patch)
tree8b9d1690dc20ccfde0c2c9876b2c7823f130e695
parent491cbd3553f36983555bd0aa22124dc580f6484b (diff)
downloadgnu-guix-6101cad4d19cf1c32d6abf7c9ef2a86ad9d986c5.tar
gnu-guix-6101cad4d19cf1c32d6abf7c9ef2a86ad9d986c5.tar.gz
gnu: Add geomyidae.
* gnu/packages/web.scm (geomyidae): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index eb3257362b..eb0436cb35 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6113,3 +6113,38 @@ based on this library, allowing Perl programmers to easily validate HTML.")
object. It's meant as a replacement for @code{HTML::Lint}, which is written
in Perl but is not nearly as capable as @code{HTML::Tidy}.")
(license l:artistic2.0)))
+
+(define-public geomyidae
+ (package
+ (name "geomyidae")
+ (version "0.29")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://git.r-36.net/geomyidae/snapshot/"
+ "geomyidae-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0qxgxp6psfrgfqhndyq2z54nb1qrmvvljddnxdwp207jbz366bja"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://git.r-36.net/geomyidae")
+ (synopsis "Small Gopher server")
+ (description
+ "Geomyidae is a server for distributed hypertext protocol Gopher. Its
+features include:
+
+@enumerate
+@item Gopher menus (see @file{index.gph} for an example);
+@item directory listings (if no @file{index.gph} was found);
+@item CGI support (@file{.cgi} files are executed);
+@item search support in CGI files;
+@item logging with multiple log levels.
+@end enumerate\n")
+ (license l:expat)))