summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:57:23 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commit608c4d8ebbe1a9ad73baa4b511512e8f6e0f1f83 (patch)
tree3ccb0d7e6705c0c0fbaa871d296ceefb2aa6aa07
parent3e7de7ce4fc696a78fa0107ac1f3c304a25f936a (diff)
downloadgnu-guix-608c4d8ebbe1a9ad73baa4b511512e8f6e0f1f83.tar
gnu-guix-608c4d8ebbe1a9ad73baa4b511512e8f6e0f1f83.tar.gz
gnu: Add python-rstcheck.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9a6de42041..7ead34d5b9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15549,3 +15549,25 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(synopsis "reStructuredText linter")
(description "reStructuredText linter")
(license #f)))
+
+(define-public python-rstcheck
+ (package
+ (name "python-rstcheck")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rstcheck" version))
+ (sha256
+ (base32
+ "1pr1zcd77fj97q6kiz5rfs0nrz1mjwijr4jylcvfk9ca6cyqjnhm"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils"
+ ,python-docutils)))
+ (home-page "https://github.com/myint/rstcheck")
+ (synopsis
+ "Checks syntax of reStructuredText and code blocks nested within it")
+ (description
+ "Checks syntax of reStructuredText and code blocks nested within it")
+ (license #f)))