summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-04-14 19:09:27 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commit532a0990f0e548df694c53e62e35301171b0762e (patch)
tree1155489363b434df332b8863289d339c5bc88ce5
parenta70113a0b3d0a1bba8d3da04df6fa6399bd01426 (diff)
downloadgnu-guix-532a0990f0e548df694c53e62e35301171b0762e.tar
gnu-guix-532a0990f0e548df694c53e62e35301171b0762e.tar.gz
gnu: Add ruby-raindrops.
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 20a697bcab..9b40d7c3c6 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9005,3 +9005,32 @@ non-blocking I/O methods for Ruby without raising exceptions on
EAGAIN and EINPROGRESS.")
(home-page "https://bogomips.org/kgio/")
(license #f)))
+
+(define-public ruby-raindrops
+ (package
+ (name "ruby-raindrops")
+ (version "0.19.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "raindrops" version))
+ (sha256
+ (base32
+ "1qpbd9jif40c53fz2r0l8khfl016y8s8bkx37ibcaafclbl3xygp"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "raindrops is a real-time stats toolkit to show statistics for Rack HTTP
+servers. It is designed for preforking servers such as unicorn, but
+should support any Rack HTTP server on platforms supporting POSIX shared
+memory. It may also be used as a generic scoreboard for sharing atomic
+counters across multiple processes.")
+ (description
+ "raindrops is a real-time stats toolkit to show statistics for Rack HTTP
+servers. It is designed for preforking servers such as unicorn, but
+should support any Rack HTTP server on platforms supporting POSIX shared
+memory. It may also be used as a generic scoreboard for sharing atomic
+counters across multiple processes.")
+ (home-page "https://bogomips.org/raindrops/")
+ (license #f)))