summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:42:08 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:01:11 +0000
commit4c4f9f776c7a2a38fe82e10cbd4038770e8d5da1 (patch)
treea9b33f94c8316e3a722f3d3b3d8fb22763e87356
parent6f5480c0f74e36e233ff90e3107bcaa5a8b2f728 (diff)
downloadgnu-guix-4c4f9f776c7a2a38fe82e10cbd4038770e8d5da1.tar
gnu-guix-4c4f9f776c7a2a38fe82e10cbd4038770e8d5da1.tar.gz
gnu: Add ruby-event-bus.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 618eef5adc..cbaafdaddb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1317,6 +1317,34 @@ support.")
(home-page "https://github.com/rails/execjs")
(license license:expat)))
+(define-public ruby-event-bus
+ (package
+ (name "ruby-event-bus")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "event-bus" version))
+ (sha256
+ (base32
+ "0bqcznr15q1346avpddnyd9144hqdww86yfpb4jayaj6lm0fqwyq"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; disable testing to break the cycle with aruba. Instead simply test that
+ ;; the library can be require'd.
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "-r" "event/bus")))))))
+ (synopsis
+ "This gem notifies subscribers about event")
+ (description
+ "This gem notifies subscribers about event")
+ (home-page
+ "https://github.com/cucumber/event-bus")
+ (license license:expat)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")